summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-21 20:38:08 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-21 20:42:04 +0100
commit8e01db4711ed10e1be623ba773ff5b7782888a2d (patch)
treedfa4bd6e598202a4e32f31f5e00444dee10844a5 /dev-python/uv
parentdev-python/uv: Add dependency on dev-libs/libgit2 (diff)
downloadgentoo-8e01db4711ed10e1be623ba773ff5b7782888a2d.tar.gz
gentoo-8e01db4711ed10e1be623ba773ff5b7782888a2d.tar.bz2
gentoo-8e01db4711ed10e1be623ba773ff5b7782888a2d.zip
dev-python/uv: Update skipped tests
Now that Python 3.8 and 3.9 have been bumped, and there is a new packaging release, more tests are failing, sigh. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uv')
-rw-r--r--dev-python/uv/files/uv-0.1.13-skip-tests.patch34
-rw-r--r--dev-python/uv/uv-0.1.13-r1.ebuild23
2 files changed, 39 insertions, 18 deletions
diff --git a/dev-python/uv/files/uv-0.1.13-skip-tests.patch b/dev-python/uv/files/uv-0.1.13-skip-tests.patch
index 5dccfe525f81..440d78bddd01 100644
--- a/dev-python/uv/files/uv-0.1.13-skip-tests.patch
+++ b/dev-python/uv/files/uv-0.1.13-skip-tests.patch
@@ -1,19 +1,35 @@
-diff --git a/crates/uv/tests/pip_compile_scenarios.rs b/crates/uv/tests/pip_compile_scenarios.rs
-index 2cbece6d..9b785300 100644
---- a/crates/uv/tests/pip_compile_scenarios.rs
-+++ b/crates/uv/tests/pip_compile_scenarios.rs
-@@ -118,3 +118,2 @@ fn requires_incompatible_python_version_compatible_override() -> Result<()> {
- /// ```
+diff --git a/crates/uv/tests/pip_install.rs b/crates/uv/tests/pip_install.rs
+index bb6f719e..e8628b4d 100644
+--- a/crates/uv/tests/pip_install.rs
++++ b/crates/uv/tests/pip_install.rs
+@@ -827,3 +827,2 @@ fn install_no_index_version() {
+ /// Ref: <https://github.com/astral-sh/uv/issues/1600>
-#[test]
- fn requires_compatible_python_version_incompatible_override() -> Result<()> {
+ fn install_extra_index_url_has_priority() {
diff --git a/crates/uv/tests/pip_install_scenarios.rs b/crates/uv/tests/pip_install_scenarios.rs
-index e0ad34ec..87bff298 100644
+index e0ad34ec..4e0c33c9 100644
--- a/crates/uv/tests/pip_install_scenarios.rs
+++ b/crates/uv/tests/pip_install_scenarios.rs
-@@ -2369,3 +2369,2 @@ fn requires_python_version_greater_than_current() {
+@@ -2246,3 +2246,2 @@ fn package_prereleases_specifier_boundary() {
+ /// ```
+-#[test]
+ fn requires_python_version_does_not_exist() {
+@@ -2287,3 +2286,2 @@ fn requires_python_version_does_not_exist() {
+ /// ```
+-#[test]
+ fn requires_python_version_less_than_current() {
+@@ -2328,3 +2326,2 @@ fn requires_python_version_less_than_current() {
+ /// ```
+-#[test]
+ fn requires_python_version_greater_than_current() {
+@@ -2369,3 +2366,2 @@ fn requires_python_version_greater_than_current() {
/// ```
-#[test]
fn requires_python_version_greater_than_current_patch() {
+@@ -2529,3 +2525,2 @@ fn requires_python_version_greater_than_current_backtrack() {
+ /// ```
+-#[test]
+ fn requires_python_version_greater_than_current_excluded() {
diff --git a/crates/uv/tests/pip_list.rs b/crates/uv/tests/pip_list.rs
index 71bdf344..b80fea5f 100644
--- a/crates/uv/tests/pip_list.rs
diff --git a/dev-python/uv/uv-0.1.13-r1.ebuild b/dev-python/uv/uv-0.1.13-r1.ebuild
index 5e3cdac4d27a..b610be166f23 100644
--- a/dev-python/uv/uv-0.1.13-r1.ebuild
+++ b/dev-python/uv/uv-0.1.13-r1.ebuild
@@ -62,14 +62,6 @@ BDEPEND="
)
"
-PATCHES=(
- # skip broken tests:
- # - requiring pinned CPython versions (3.8.12, 3.11.7, 3.12.1)
- # - requiring specific terminal width (COLUMNS don't seem to work)
- # - other (perhaps failing because of other skipped tests?)
- "${FILESDIR}/uv-0.1.13-skip-tests.patch"
-)
-
QA_FLAGS_IGNORED="usr/bin/.*"
check_space() {
@@ -86,6 +78,19 @@ pkg_setup() {
check_space
}
+src_prepare() {
+ local PATCHES=(
+ # skip broken tests:
+ # - requiring pinned CPython versions (3.8.12, 3.11.7, 3.12.1)
+ # - requiring specific terminal width (COLUMNS don't seem to work)
+ # - other (perhaps failing because of other skipped tests?)
+ "${FILESDIR}/uv-0.1.13-skip-tests.patch"
+ )
+
+ rm crates/uv/tests/pip_compile_scenarios.rs || die
+ default
+}
+
src_compile() {
cd crates/uv || die
cargo_src_compile
@@ -93,7 +98,7 @@ src_compile() {
src_test() {
cd crates/uv || die
- cargo_src_test
+ cargo_src_test --no-fail-fast
}
src_install() {