summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-04 07:12:11 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-04 07:12:11 +0100
commitf3c062ecade1eef9d071b410bd5b8ca3df318ae0 (patch)
treeb770f33f044fb543df9e1f0d6c388026565015e2 /dev-python/wand
parentapp-admin/awscli: Bump to 1.29.78 (diff)
downloadgentoo-f3c062ecade1eef9d071b410bd5b8ca3df318ae0.tar.gz
gentoo-f3c062ecade1eef9d071b410bd5b8ca3df318ae0.tar.bz2
gentoo-f3c062ecade1eef9d071b410bd5b8ca3df318ae0.zip
dev-python/wand: Bump to 0.6.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wand')
-rw-r--r--dev-python/wand/Manifest1
-rw-r--r--dev-python/wand/wand-0.6.13.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/wand/Manifest b/dev-python/wand/Manifest
index 4ed009b89441..b153a8e4fcd1 100644
--- a/dev-python/wand/Manifest
+++ b/dev-python/wand/Manifest
@@ -1 +1,2 @@
DIST Wand-0.6.11.tar.gz 11883567 BLAKE2B 561bcf6645f6eb41737c5e999f01e2719b5170d6e662e3812b4bd444fa77331175a22eff95eeb94ce17ecbe6dbef9a97e9a4f509f878431b64b357843fb15061 SHA512 4e551c2942835872f52247c2d642faf2ad4bad6bb206376e4f8dc5cdabe981e73b7e0f58a705d5dcbf8f95c445ed13bbe6b8443b9b29d0056e7aaf50565a608d
+DIST Wand-0.6.13.tar.gz 11883700 BLAKE2B b4764d87a5a71acae42ef41b6f066649d9df675045c78de49a64d2a6fa440d0ae995ef20c02ae8fa40af9d728d0b91a43f0371ea220afbae13d3bb9ed3742cd4 SHA512 a166a365474e3c4442b1c0fc521837026a236d416b7cf3f899acee5f3b1febb4c5deb0b75bf158393fb9df60e37e6cd8d528cdfdb637a19ecd271ba841dfada2
diff --git a/dev-python/wand/wand-0.6.13.ebuild b/dev-python/wand/wand-0.6.13.ebuild
new file mode 100644
index 000000000000..c3f0ea330f3e
--- /dev/null
+++ b/dev-python/wand/wand-0.6.13.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Ctypes-based simple ImageMagick binding for Python"
+HOMEPAGE="
+ https://docs.wand-py.org/
+ https://github.com/emcconville/wand/
+ https://pypi.org/project/Wand/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-gfx/imagemagick
+"
+BDEPEND="
+ test? (
+ media-gfx/imagemagick[fftw,jpeg,png,truetype,xml]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ # PDF support is blocked by the default ImageMagick security policy
+ epytest --skip-pdf
+}