summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/watchdog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/watchdog')
-rw-r--r--dev-python/watchdog/Manifest3
-rw-r--r--dev-python/watchdog/metadata.xml12
-rw-r--r--dev-python/watchdog/watchdog-0.8.1.ebuild27
-rw-r--r--dev-python/watchdog/watchdog-0.8.2.ebuild37
-rw-r--r--dev-python/watchdog/watchdog-0.8.3.ebuild37
5 files changed, 116 insertions, 0 deletions
diff --git a/dev-python/watchdog/Manifest b/dev-python/watchdog/Manifest
new file mode 100644
index 000000000000..be8a93d137d4
--- /dev/null
+++ b/dev-python/watchdog/Manifest
@@ -0,0 +1,3 @@
+DIST watchdog-0.8.1.tar.gz 154747 SHA256 d6ec6be582b244834a888c8ccc2d451816184ab104b5454b5e5cd7649e8f671c SHA512 d5915be2e2817c748c6d2ba91d8a4044938fa5665019ac7c2048e28493c0dba34189bef61cd642204f1bd62d81ef59767af5970f65543a0c981d8f31ab980856 WHIRLPOOL 94890aa9a0a19c49ce2358b694a61b456df270da3a16d5c5e91044a96e228026288c7dcb7d4597e5fddae601692f8b34cae5e2a29ad388bc08aaf86b3d59fcb8
+DIST watchdog-0.8.2.tar.gz 157936 SHA256 33a9ab3ce2e6b1aca4d2a50752231668d69bdba4ab096d9742195ccfbef1e023 SHA512 96f1fcd0d6898ce950c8768000be2f619c9a28c9d96cb1d7323f04371b065e50b38692179949255bb13fa4e3c72e6f656dbc02b4d7f77b7fb3aacdf08600cb71 WHIRLPOOL c2581e9dba65f8ffbe1fe8b21d873e0292aae6ba46012979b221b3d4ede8f74d4c2cc2efa8635e99180c3bce227f943cb5ef4fba3dd24f5dae5bfc150f643c1d
+DIST watchdog-0.8.3.tar.gz 83154 SHA256 7e65882adb7746039b6f3876ee174952f8eaaa34491ba34333ddf1fe35de4162 SHA512 61f1db886e8e9a6d78b569329f4d5944c296778a5a34f94fbf115a748fb4c3be422bf4d3cc828e22fcdcd380fdf9009f5bd91a8a5edc87089afc58297a0b946f WHIRLPOOL 54af63f60711afac83d79d8b2e67c8dd500eb73a9ea89d6341979406dce4942cec071141b6aaa98615eb7b097d82a915043cbbe8166589c805beab163e733480
diff --git a/dev-python/watchdog/metadata.xml b/dev-python/watchdog/metadata.xml
new file mode 100644
index 000000000000..378220de1467
--- /dev/null
+++ b/dev-python/watchdog/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">watchdog</remote-id>
+ <remote-id type="github">gorakhargosh/watchdog</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/watchdog/watchdog-0.8.1.ebuild b/dev-python/watchdog/watchdog-0.8.1.ebuild
new file mode 100644
index 000000000000..9bec1111a734
--- /dev/null
+++ b/dev-python/watchdog/watchdog-0.8.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="http://github.com/gorakhargosh/watchdog"
+SRC_URI="mirror://pypi/w/watchdog/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/pathtools[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}
diff --git a/dev-python/watchdog/watchdog-0.8.2.ebuild b/dev-python/watchdog/watchdog-0.8.2.ebuild
new file mode 100644
index 000000000000..e6bb2c469605
--- /dev/null
+++ b/dev-python/watchdog/watchdog-0.8.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy)
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="http://github.com/gorakhargosh/watchdog"
+SRC_URI="mirror://pypi/w/watchdog/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/pathtools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-python/pytest
+ dev-python/pytest-cov
+ >=dev-python/pytest-timeout-0.3
+ )"
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}
diff --git a/dev-python/watchdog/watchdog-0.8.3.ebuild b/dev-python/watchdog/watchdog-0.8.3.ebuild
new file mode 100644
index 000000000000..1d7ccc3a7ce8
--- /dev/null
+++ b/dev-python/watchdog/watchdog-0.8.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy)
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="http://github.com/gorakhargosh/watchdog"
+SRC_URI="mirror://pypi/w/watchdog/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/pathtools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}