summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-08 12:56:38 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-08 13:09:52 +0200
commitc6281e3efd0a2b60bf11dc6a074165333b34b83c (patch)
tree9b94d544e5aed294bf28a5ae185cb19bbdaddda8 /dev-python/watchgod
parentdev-python/watchgod: Enable pypy3 (diff)
downloadgentoo-c6281e3efd0a2b60bf11dc6a074165333b34b83c.tar.gz
gentoo-c6281e3efd0a2b60bf11dc6a074165333b34b83c.tar.bz2
gentoo-c6281e3efd0a2b60bf11dc6a074165333b34b83c.zip
dev-python/watchgod: Enable pypy3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/watchgod')
-rw-r--r--dev-python/watchgod/watchgod-0.8.1.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/dev-python/watchgod/watchgod-0.8.1.ebuild b/dev-python/watchgod/watchgod-0.8.1.ebuild
index be3e64483bb4..4e6dd5a7db55 100644
--- a/dev-python/watchgod/watchgod-0.8.1.ebuild
+++ b/dev-python/watchgod/watchgod-0.8.1.ebuild
@@ -35,10 +35,6 @@ BDEPEND="
distutils_enable_tests pytest
-EPYTEST_DESELECT=(
- # flaky test on slow systems, https://github.com/samuelcolvin/watchgod/issues/84
- tests/test_watch.py::test_awatch_log
-)
src_prepare() {
# increase timeout
@@ -46,3 +42,14 @@ src_prepare() {
distutils-r1_src_prepare
}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # flaky test on slow systems, https://github.com/samuelcolvin/watchgod/issues/84
+ tests/test_watch.py::test_awatch_log
+ )
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ tests/test_watch.py::test_does_not_exist
+ )
+ epytest
+}