summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/webassets
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/webassets')
-rw-r--r--dev-python/webassets/Manifest1
-rw-r--r--dev-python/webassets/metadata.xml11
-rw-r--r--dev-python/webassets/webassets-0.10.1.ebuild19
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/webassets/Manifest b/dev-python/webassets/Manifest
new file mode 100644
index 000000000000..7f4f797484bd
--- /dev/null
+++ b/dev-python/webassets/Manifest
@@ -0,0 +1 @@
+DIST webassets-0.10.1.tar.gz 171666 SHA256 8e7dedd8032a963ef7e55e670cc109927e1f153b35cf8e9634617d0c6ee93329 SHA512 2879630608c3bd6904bc9f7ab6eceae899df967856e6d7b6dd125106ca27635993bf34309e320a0deacdb3b31020b69d59b4f85afdeae259b4915557c5ae6134 WHIRLPOOL 315e0a0e836683d4750e176ce89fb929e4027f8a32dcf941d0c5faf3c356923ff7db9b8b19d41bd6741ba41c68fd9c96a8f16d7af98b8efdabcf2afeadbd4953
diff --git a/dev-python/webassets/metadata.xml b/dev-python/webassets/metadata.xml
new file mode 100644
index 000000000000..4fa00587b82a
--- /dev/null
+++ b/dev-python/webassets/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">miracle2k/webassets</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/webassets/webassets-0.10.1.ebuild b/dev-python/webassets/webassets-0.10.1.ebuild
new file mode 100644
index 000000000000..d9652ad22f15
--- /dev/null
+++ b/dev-python/webassets/webassets-0.10.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="Asset management for Python web development"
+HOMEPAGE="https://github.com/miracle2k/webassets"
+SRC_URI="https://github.com/miracle2k/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"