summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-03 17:44:10 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-03 17:49:31 +0200
commit767f77e083609b7feea866cee66697b22e396e7e (patch)
treeaed2f1fcca1f0a89da26d6402f7f1accb244059d /dev-python/websockify/websockify-0.12.0.ebuild
parentdev-python/pipdeptree: Bump to 2.22.0 (diff)
downloadgentoo-767f77e083609b7feea866cee66697b22e396e7e.tar.gz
gentoo-767f77e083609b7feea866cee66697b22e396e7e.tar.bz2
gentoo-767f77e083609b7feea866cee66697b22e396e7e.zip
dev-python/websockify: Bump to 0.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/websockify/websockify-0.12.0.ebuild')
-rw-r--r--dev-python/websockify/websockify-0.12.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/websockify/websockify-0.12.0.ebuild b/dev-python/websockify/websockify-0.12.0.ebuild
new file mode 100644
index 000000000000..5ca03c37fb19
--- /dev/null
+++ b/dev-python/websockify/websockify-0.12.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSockets support for any application/server"
+HOMEPAGE="
+ https://github.com/novnc/websockify/
+ https://pypi.org/project/websockify/
+"
+SRC_URI="
+ https://github.com/novnc/websockify/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/jwcrypto[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/redis[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ doman docs/${PN}.1
+ distutils-r1_python_install_all
+}