summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-06 09:23:34 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-06 09:33:03 +0200
commit5efecf213169b9ab955ed2b37cf953cd258e7206 (patch)
tree57e843375a3b61daa25c8ac57ce0330a3b5b63c3 /dev-python/zeroconf
parentdev-python/django: Remove vulnerable versions (diff)
downloadgentoo-5efecf213169b9ab955ed2b37cf953cd258e7206.tar.gz
gentoo-5efecf213169b9ab955ed2b37cf953cd258e7206.tar.bz2
gentoo-5efecf213169b9ab955ed2b37cf953cd258e7206.zip
dev-python/zeroconf: Bump to 0.30.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.30.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 18148fa854ae..632a025e172a 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1 +1,2 @@
DIST python-zeroconf-0.29.0.gh.tar.gz 62466 BLAKE2B 430a9f4d4460d66166a2484862a8dd3af65f3cfad0e25557648abf26ebe88a7ae581934273db270ff30fa4d714b32a822448b22fd7a95e9e382b68ffae9b66b4 SHA512 a084da17cda264b531e7f58975d30ae0b5adb98f33ca78d1e865e1450dc42ad2bca69bc319c268f7977e70e082ae713142a57f97a9f050486c47b50698002590
+DIST python-zeroconf-0.30.0.gh.tar.gz 64301 BLAKE2B ea0d5e36f3f012f217cbd4eeff0a9cd366496e2f64b06112ee3629ad016c8e28877f62358d5b5fd27387cfe474e488e99a9ad8ca1802f6d23612f99310243c57 SHA512 1f3165500a07525ef182bb60c1804fe2002a33a9f800470bdb32bdfd44a1b8f466a818a4390537674952159e5c0e257cf9e4ca570b1a9936e1cf8be294be6311
diff --git a/dev-python/zeroconf/zeroconf-0.30.0.ebuild b/dev-python/zeroconf/zeroconf-0.30.0.ebuild
new file mode 100644
index 000000000000..7468e3466c5c
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.30.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local excludes=(
+ # network
+ zeroconf/test.py::Framework::test_close_multiple_times
+ zeroconf/test.py::Framework::test_launch_and_close
+ zeroconf/test.py::Framework::test_launch_and_close_v4_v6
+ zeroconf/test.py::Framework::test_launch_and_close_v6_only
+ zeroconf/test.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+ )
+
+ epytest ${excludes[@]/#/--deselect } zeroconf/test.py
+}