summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-12 04:28:05 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-12 04:50:33 +0200
commitf1869c9199e60aec93f1a4d0e97c1b44835eb226 (patch)
tree684066592dd457b1357944d6708b3c811db0e942 /dev-python/zipp
parentdev-python/zipp: Bump to 3.19.3 (diff)
downloadgentoo-f1869c9199e60aec93f1a4d0e97c1b44835eb226.tar.gz
gentoo-f1869c9199e60aec93f1a4d0e97c1b44835eb226.tar.bz2
gentoo-f1869c9199e60aec93f1a4d0e97c1b44835eb226.zip
dev-python/zipp: Bump to 3.20.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-3.20.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index c2cd8959d991..02c296f3185e 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1,2 +1,3 @@
DIST zipp-3.19.2.tar.gz 22922 BLAKE2B 8f4a115079b6faa730a3502592983c13b2db27541cdbd91723fd20f320d22678f3740b01f24b46f7049607c49953ea64fa8e4855d26f28f0683d330b625a2d0b SHA512 3f1b663c4befef774e076845a8a2d2fc414cb768af0e3bccc57b6b694e9ef28e8dd8ae59b596b269f610b082e9c7a92ec3dcd465aad4e5ebe250ea96df89b2cf
DIST zipp-3.19.3.tar.gz 23169 BLAKE2B be8ab50de2edb2262e78a7047fd06a10a31414b534a649b0ae3297d4ed843fb33141d1fc563accb4dd71b23b7ef7d161f16045139a90349dc757a72d1cf9320a SHA512 a76d50e6405b40dab4806662a26aaf0cff096a8d2462e0da9d81abd1675d64d8c520391277e8225e912a220f1e7965c754e8db24e9917343f2a0808b51a4f69e
+DIST zipp-3.20.0.tar.gz 23244 BLAKE2B cc7d336089b4659ac884658f93246045a617d223cc3db538160cef1d705e781d341f6384ab32928e7ef2c6644cf6a0656f2b6fa23077da5df0ec66d9b2337b8f SHA512 c141c4b8bdaf2ff7639cfb85ba36735da1ca33e68b9fdcb7f350e5bd677ca39def00178aa3d481c733162beed4aa70f93525800f1af0618529ff36ca7e32327e
diff --git a/dev-python/zipp/zipp-3.20.0.ebuild b/dev-python/zipp/zipp-3.20.0.ebuild
new file mode 100644
index 000000000000..56691701c850
--- /dev/null
+++ b/dev-python/zipp/zipp-3.20.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="
+ https://github.com/jaraco/zipp/
+ https://pypi.org/project/zipp/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+# big_o is only used in test_complexity, that we ignore
+BDEPEND="
+ test? (
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/jaraco-itertools[${PYTHON_USEDEP}]
+ dev-python/jaraco-test[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # performance tests are flaky by design
+ tests/test_complexity.py
+)
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "zipp"
+ version = "${PV}"
+ description = "Backport of pathlib-compatible object wrapper for zip files"
+ EOF
+}