summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-18 07:09:09 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-18 08:47:10 +0200
commit09eee2eb48b8b35058d9fc72682a5444c3de8830 (patch)
tree895540fa54ef52fe8e17a1f00e4fe5eba5b04b7b /dev-python
parentdev-python/PyPDF2: Bump to 2.2.1 (diff)
downloadgentoo-09eee2eb48b8b35058d9fc72682a5444c3de8830.tar.gz
gentoo-09eee2eb48b8b35058d9fc72682a5444c3de8830.tar.bz2
gentoo-09eee2eb48b8b35058d9fc72682a5444c3de8830.zip
dev-python/oslo-utils: Bump to 5.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/oslo-utils/Manifest1
-rw-r--r--dev-python/oslo-utils/oslo-utils-5.0.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/oslo-utils/Manifest b/dev-python/oslo-utils/Manifest
index cb3190e6e02a..0154c9389355 100644
--- a/dev-python/oslo-utils/Manifest
+++ b/dev-python/oslo-utils/Manifest
@@ -1 +1,2 @@
DIST oslo.utils-4.13.0.tar.gz 101834 BLAKE2B 9d3457ee9ce1746869120bf66d83495b4e1f2b4ca005285fa121ff4c176e85148662cd1de52bdaf93dc18d85478f2cbfde9b310e748b895f01c77ef82019dc0e SHA512 1d97fdaab79cc6c4cc34efdafca7263a2679e60d446aadc46fe31d7fdda2051b37f9df79d149644d914c7274e7fa2d9ef6a1c1aeafad8a1333221dcbe65f4723
+DIST oslo.utils-5.0.0.tar.gz 101823 BLAKE2B be62ddc2fb9130e3f678366b6181f1f334f95846a09ede4a08917cd88427492978e53039a482a7158f234caf96c9e520026ab6009f1df5de588a9fe68aa0664f SHA512 8941caf086354c9066ef51e64dcab5854b8d99c2b51807cb2d8b75fac0983f5787e499b0727423b624791ead2b5c9b55b463d5ff47f7586f3e302dccec1f5408
diff --git a/dev-python/oslo-utils/oslo-utils-5.0.0.ebuild b/dev-python/oslo-utils/oslo-utils-5.0.0.ebuild
new file mode 100644
index 000000000000..a0bf0d0fa37e
--- /dev/null
+++ b/dev-python/oslo-utils/oslo-utils-5.0.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Oslo Utility library"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.2.0[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/eventlet-0.23.0[${PYTHON_USEDEP}]
+ ' python3_{8..9})
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # spurious rdep
+ sed -i -e '/pbr/d' requirements.txt || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ if ! has "${EPYTHON}" python3.{8..9}; then
+ find "${BUILD_DIR}"/install -name '*eventletutils*.py' -delete || die
+ fi
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}