summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-22 17:52:33 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-22 18:00:47 -0400
commit10be7674d7f7a259ac70c1462d1697e8a4f2db9b (patch)
tree31c10ca4a6b2c345ccc36f46e4fac84db7a1dbd4 /dev-python
parentdev-python/snakeoil: version bump to 0.7.2 (diff)
downloadgentoo-10be7674d7f7a259ac70c1462d1697e8a4f2db9b.tar.gz
gentoo-10be7674d7f7a259ac70c1462d1697e8a4f2db9b.tar.bz2
gentoo-10be7674d7f7a259ac70c1462d1697e8a4f2db9b.zip
dev-python/pychroot: version bump to 0.9.17
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pychroot/Manifest1
-rw-r--r--dev-python/pychroot/pychroot-0.9.17.ebuild49
-rw-r--r--dev-python/pychroot/pychroot-9999.ebuild11
3 files changed, 57 insertions, 4 deletions
diff --git a/dev-python/pychroot/Manifest b/dev-python/pychroot/Manifest
index 9724556ae91b..296755c78e08 100644
--- a/dev-python/pychroot/Manifest
+++ b/dev-python/pychroot/Manifest
@@ -1 +1,2 @@
DIST pychroot-0.9.16.tar.gz 31027 SHA256 8bcfde4f045d34181ab6ec869abb6608c1340de4dd15ceac003287ec610d221d SHA512 6e35c7b40ad27d234c855abf1857aa6579583d848b111559de21edfa0bc6987e08d1d122924101e2e9bdf37886591b7291a607ed22cf2c50aa11b32f7ea65495 WHIRLPOOL 234cdd15e1cda4473d061ec03f8be75560785ca53c441750372d34545e6e0a1d068a2bf9f652cc60486793fb294d3af1d68834602ab0e0160e4194a2a0f6a98d
+DIST pychroot-0.9.17.tar.gz 32036 SHA256 4556d110ab3270c2eec817c1e9573e14fe851a9034ee45b4d96b2695f812c467 SHA512 d99b3875e72fc8553d29cc87c4a30b714cc5dcfbff717eb79be26b1cb0590a1c7dab8dcf66528b2805e5eb91a7619c4015b08ff2194470d9d41e94d82bc44971 WHIRLPOOL 7790adeaa8d7699e01a79adfc6c51d9bdf40cec03c1609b1446d8c18b0db2002492a36671d4b37e4ac1e51ef347c663a8e91033722dd4276044a6fe6424f9d38
diff --git a/dev-python/pychroot/pychroot-0.9.17.ebuild b/dev-python/pychroot/pychroot-0.9.17.ebuild
new file mode 100644
index 000000000000..fe3de49275b7
--- /dev/null
+++ b/dev-python/pychroot/pychroot-0.9.17.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pychroot.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a python library and cli tool that simplify chroot handling"
+HOMEPAGE="https://github.com/pkgcore/pychroot"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND="=dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND=">=dev-python/snakeoil-0.7.2[${PYTHON_USEDEP}]"
+fi
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ esetup.py build_man
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst README.rst )
+ distutils-r1_python_install install_man
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pychroot/pychroot-9999.ebuild b/dev-python/pychroot/pychroot-9999.ebuild
index 9809bcd783a7..fe3de49275b7 100644
--- a/dev-python/pychroot/pychroot-9999.ebuild
+++ b/dev-python/pychroot/pychroot-9999.ebuild
@@ -10,7 +10,7 @@ if [[ ${PV} == *9999 ]] ; then
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/pkgcore/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
fi
DESCRIPTION="a python library and cli tool that simplify chroot handling"
@@ -20,9 +20,12 @@ LICENSE="BSD"
SLOT="0"
IUSE="test"
-RDEPEND="
- =dev-python/snakeoil-9999[${PYTHON_USEDEP}]
-"
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND="=dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND=">=dev-python/snakeoil-0.7.2[${PYTHON_USEDEP}]"
+fi
+
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (