summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-15 15:21:30 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-15 15:21:30 +0100
commit17b41ec215d8756525f7030199e24aa4de32b37a (patch)
tree8c387f4b3b10dabfb177ddd439b1e086f71f41f9 /dev-python
parentdev-python/sphinx-bootstrap-theme: Remove old (diff)
downloadgentoo-17b41ec215d8756525f7030199e24aa4de32b37a.tar.gz
gentoo-17b41ec215d8756525f7030199e24aa4de32b37a.tar.bz2
gentoo-17b41ec215d8756525f7030199e24aa4de32b37a.zip
dev-python/plyr: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/plyr/plyr-1.0.6.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/plyr/plyr-1.0.6.ebuild b/dev-python/plyr/plyr-1.0.6.ebuild
deleted file mode 100644
index 6d453c66f45e..000000000000
--- a/dev-python/plyr/plyr-1.0.6.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit distutils-r1 flag-o-matic
-
-MY_PN="python-glyr"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A python wrapper for Glyr"
-HOMEPAGE="https://sahib.github.io/python-glyr/intro.html
- https://github.com/sahib/python-glyr"
-SRC_URI="https://github.com/sahib/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-3+"
-KEYWORDS="amd64 x86"
-SLOT="0"
-
-RDEPEND="media-libs/glyr:="
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx docs
-
-python_prepare_all() {
- # Disable test requiring internet connection
- sed -e 's:test_download:_&:' -i tests/test_misc.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" -m unittest discover tests || die "Tests fail with ${EPYTHON}"
-}