summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-29 07:23:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-29 07:35:07 +0200
commit1a392c0dc5667b5d60adb3e769778d954ddac980 (patch)
tree74c797cc799904cc1857db869552c1969c1a66f7 /dev-python
parentdev-java/tomcat-servlet-api: drop 6.0.53-r1 (diff)
downloadgentoo-1a392c0dc5667b5d60adb3e769778d954ddac980.tar.gz
gentoo-1a392c0dc5667b5d60adb3e769778d954ddac980.tar.bz2
gentoo-1a392c0dc5667b5d60adb3e769778d954ddac980.zip
dev-python/black: Bump to 23.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/black/Manifest1
-rw-r--r--dev-python/black/black-23.3.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/black/Manifest b/dev-python/black/Manifest
index be50691cb5e7..8d863224e81e 100644
--- a/dev-python/black/Manifest
+++ b/dev-python/black/Manifest
@@ -1 +1,2 @@
DIST black-23.1.0.gh.tar.gz 1196151 BLAKE2B 3c81bf5e52bb08928b568a20c9b3d769c5ebdd120bdfd4565c89fbffd978cd4a93dd70eacd041a4560723987278d16acfcae49245007bdc59178264757fba74d SHA512 f86d1bcf59c3fa0bb1bc3e71511c5df435ea437fd1cb30c466b8babc9522fb96bba6261da1431db75e6d578a85d061d31bd6ddbe50327fb4a3987eb03b03c330
+DIST black-23.3.0.tar.gz 582156 BLAKE2B 01ed5443e1bb251d46618a5b61bbfcc2dc0b41c0bef7d4315fb704a2ac0fd51eb4fe268838b8be6195630f21e6f7b3a5bfca124a7bd60dbef95a02714924327b SHA512 1ea8749ee25aae34a40c5d1b779c6076971488dea1a85ebfcbe4c2a8bb5abb5e3918a735a4e3f9b4ae2690eda0f48fac014ade055721b54d879fdd2d3450b72b
diff --git a/dev-python/black/black-23.3.0.ebuild b/dev-python/black/black-23.3.0.ebuild
new file mode 100644
index 000000000000..3bbd465b752b
--- /dev/null
+++ b/dev-python/black/black-23.3.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="The uncompromising Python code formatter"
+HOMEPAGE="
+ https://black.readthedocs.io/en/stable/
+ https://github.com/psf/black/
+ https://pypi.org/project/black/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/click-8.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-22.0[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-3.10.0.0[${PYTHON_USEDEP}]
+ ' 3.9)
+"
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/aiohttp-3.7.4[${PYTHON_USEDEP}]
+ dev-python/aiohttp-cors[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "blackd - HTTP API for black" \
+ "dev-python/aiohttp dev-python/aiohttp-cors"
+}