summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-28 04:41:13 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-28 05:02:52 +0100
commit20ab6863ef75a5a8402be3c172d6cd9e363be7e5 (patch)
treedcb232c69b99eae852db7a4a252a77ce98a73038 /dev-python
parentdev-python/leechcorepyc: Bump to 2.17.0 (diff)
downloadgentoo-20ab6863ef75a5a8402be3c172d6cd9e363be7e5.tar.gz
gentoo-20ab6863ef75a5a8402be3c172d6cd9e363be7e5.tar.bz2
gentoo-20ab6863ef75a5a8402be3c172d6cd9e363be7e5.zip
dev-python/pydantic: Bump to 2.6.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pydantic/Manifest1
-rw-r--r--dev-python/pydantic/pydantic-2.6.3.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pydantic/Manifest b/dev-python/pydantic/Manifest
index 5c51af3432eb..068b76d949c0 100644
--- a/dev-python/pydantic/Manifest
+++ b/dev-python/pydantic/Manifest
@@ -5,3 +5,4 @@ DIST pydantic-2.5.3.tar.gz 651797 BLAKE2B 9494bd7a243d5cda762d916b10120861870b5f
DIST pydantic-2.6.0.tar.gz 677208 BLAKE2B 10df7e22a05fc01e1d35b71f266f852599f949080c44a3ecbee8f8b42344de13fb2bc13957d2d2104337d4311ceda537073d0dda6f8cd9c5f621d381293d4e8c SHA512 5d3912f2b388ea49ba853b6463478c0fbf15ea67877291198ef69b4dc6f037215e62dc872e62ad6152ce02de0d809c89dcd11b5b0c94e668f15eb559a3d8a536
DIST pydantic-2.6.1.tar.gz 679826 BLAKE2B d1915b20200a9a3a3e1c854ecc2c760eba7b672cb336b07426475072da08090a6adbe6d674019d314b01c92d69aa6caecb52f8f45bdf6d81bde1a1bff6230a3f SHA512 89a202165950ab741eac8441eb6c014dab50474bd4d001f90a32cff55b1b6bf36433d4ae11df8ab5e51bbcf68efb9674cece9a512c1d85f428e13fb59e2ae2c0
DIST pydantic-2.6.2.tar.gz 679956 BLAKE2B 5b1689fa0db2e4583f5df90b730520ba1c703a0745e8752778c45c84b6009e845ae9298aa9b8e393af8dd5b9ae6e8f83a17f3bfb566d2538d477bcb92b38cddf SHA512 dc96ca3639305e4e166a74aa2e445758c049fa76ca3a2a3036267b394a5f46037e3f9da637b20b715f6e27c8733d6e74b1c51a58d2aa624f1de982e4c5788301
+DIST pydantic-2.6.3.tar.gz 680427 BLAKE2B 28d8d4edcfeeae4f0ba70ed09987e26ba569c38b2c511b6d0b4277b830173302228c964f4c086ac4412a331afa3fba16d9581bd31446fb1dfb43065eb29dfc59 SHA512 2eca898328beb1f33e343d3aa7edf8847baae0569d078507a58bbe0fcf355250c72b70a33f6b79cef697f41ced91eaeee1ffc4a7712fd6fd251fd64557e390d0
diff --git a/dev-python/pydantic/pydantic-2.6.3.ebuild b/dev-python/pydantic/pydantic-2.6.3.ebuild
new file mode 100644
index 000000000000..50a75801255f
--- /dev/null
+++ b/dev-python/pydantic/pydantic-2.6.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Data parsing and validation using Python type hints"
+HOMEPAGE="
+ https://github.com/pydantic/pydantic/
+ https://pypi.org/project/pydantic/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/annotated-types-0.4.0[${PYTHON_USEDEP}]
+ ~dev-python/pydantic-core-2.16.3[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.6.1[${PYTHON_USEDEP}]
+"
+# pytest-8: https://github.com/pydantic/pydantic/issues/8674
+BDEPEND="
+ >=dev-python/hatch-fancy-pypi-readme-22.5.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/dirty-equals[${PYTHON_USEDEP}]
+ >=dev-python/email-validator-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/Faker-18.13.0[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/benchmark/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=(
+ # require pytest-examples
+ tests/test_docs.py
+ # benchmarks
+ tests/benchmarks
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_mock
+}