summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-29 16:50:08 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-29 17:03:11 +0200
commit26bed05cf076b6d5c06b14aa417046fd5301ba25 (patch)
tree9aedfc3cc71c34bdff9df249beeda5c7831a5032 /dev-python
parentapp-portage/gemato: Bump to 20.3, with py3.12 fix (diff)
downloadgentoo-26bed05cf076b6d5c06b14aa417046fd5301ba25.tar.gz
gentoo-26bed05cf076b6d5c06b14aa417046fd5301ba25.tar.bz2
gentoo-26bed05cf076b6d5c06b14aa417046fd5301ba25.zip
dev-python/immutables: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/immutables/immutables-0.19.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/immutables/immutables-0.19.ebuild b/dev-python/immutables/immutables-0.19.ebuild
index 00ef84fe2265..7fb45800af2d 100644
--- a/dev-python/immutables/immutables-0.19.ebuild
+++ b/dev-python/immutables/immutables-0.19.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1
@@ -28,6 +28,10 @@ distutils_enable_tests pytest
src_prepare() {
sed -i -e '/mypy/d' tests/conftest.py || die
distutils-r1_src_prepare
+
+ # workaround check removed from python3.12
+ # https://github.com/MagicStack/immutables/pull/103
+ export CFLAGS="${CFLAGS} -DHAVE_STDARG_PROTOTYPES=1"
}
src_test() {