summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-16 14:33:34 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-16 15:22:34 +0300
commit290a275d1fb4b5b35229d509b07812fd95039d87 (patch)
tree7bf70ddd07fc6384d8c13ab6bbcf609ecf1fc364 /dev-python
parentdev-python/pytest-tornasync: enable py3.11 (diff)
downloadgentoo-290a275d1fb4b5b35229d509b07812fd95039d87.tar.gz
gentoo-290a275d1fb4b5b35229d509b07812fd95039d87.tar.bz2
gentoo-290a275d1fb4b5b35229d509b07812fd95039d87.zip
dev-python/python-socks: enable py3.11
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-socks/python-socks-2.0.3.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/python-socks/python-socks-2.0.3.ebuild b/dev-python/python-socks/python-socks-2.0.3.ebuild
index 9afd16d096de..7a637139c9fa 100644
--- a/dev-python/python-socks/python-socks-2.0.3.ebuild
+++ b/dev-python/python-socks/python-socks-2.0.3.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
@@ -36,3 +36,8 @@ BDEPEND="
)"
distutils_enable_tests pytest
+
+python_test() {
+ # can be removed on next version bump
+ epytest --asyncio-mode=strict
+}