summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-23 01:31:23 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-23 01:54:53 +0100
commit3216ed2e05a0561fd841f03ec8cf61449d8cce44 (patch)
tree26c10ddf88059890bedb028191117bff32f8c72e /dev-python
parentdev-python/markdown2: Bump to 2.4.0 (diff)
downloadgentoo-3216ed2e05a0561fd841f03ec8cf61449d8cce44.tar.gz
gentoo-3216ed2e05a0561fd841f03ec8cf61449d8cce44.tar.bz2
gentoo-3216ed2e05a0561fd841f03ec8cf61449d8cce44.zip
dev-python/botocore: Bump to 1.19.59
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.59.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index aecd0f15036a..0fd9a1bdb9a0 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.19.50.tar.gz 7382888 BLAKE2B 7de2ef7a7d051427191b13cdd47d3ebd9b4
DIST botocore-1.19.56.tar.gz 7390812 BLAKE2B 3bec12ce19f39f12a72f7f59f226568cb5af59d6f9a40447a7a1fdc0f27eea06d0cfe5a5b12d2152189b700ddaa016592e95059fa42208c590cb698c568c2d63 SHA512 76988a7ddc588dba48f2444a99159247a0f178c67378fcb6eac51e3f5cfd0ab385960f0fb68bbc483f79e74c9b891070d34a39e9566eb8c24ce903b9ae24dfa5
DIST botocore-1.19.57.tar.gz 7393040 BLAKE2B 1eb29dbf95a373fc516febfe2222129f42f2c82fc37a5a6c8e1519b3f5fe63e760c0b4440573c7eb86c94a1463ecddc3046c024cc0415fe53e1a76e9362edc71 SHA512 da4cc5009a755f3be975169ba5226586f4de425f3bed2ea6eda3235bd4fc4591155715a410f47073afa7f606b290f371e776643b0d8d43a00313599630f7390a
DIST botocore-1.19.58.tar.gz 7395107 BLAKE2B 8ec21595faef30401cc84802cd1863cf9557240e733d2bd4c9ce2418f8fa3ab93d5e7f7fb4a3e35f0a5f4bc3c79bdc87be1fed3d5a66943a545d263d674cf54e SHA512 8fc7348df4a755097ba6c68db67f4685c137ccd2a82257d035588cab6dc72a4765aaf8c9748962a4e5ee5b19f8aa0c5f25feac051592464a04acad27e8fd1e09
+DIST botocore-1.19.59.tar.gz 7430783 BLAKE2B 1837dc9c3dd2948dcb37adbe5b0421c0dc4fbd245be94ef5947f8544e06b271670a78e1927cd3805906389855d973801b45b615b89dcc7c766a5252dad76d5ea SHA512 c3a9cafe5f1f8c7fecf41a7119d0b99062c4bc9be0cd1f0a7e255a13e9809af05b5e8b1e4468afda3236e8babd080241d1dc237ef668161933b5d722b3e3f7dd
diff --git a/dev-python/botocore/botocore-1.19.59.ebuild b/dev-python/botocore/botocore-1.19.59.ebuild
new file mode 100644
index 000000000000..fa25adc1c1ff
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.59.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}