summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-05 05:22:39 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-05 05:59:57 +0100
commit599ef8110cc5ddd00e264445ded976377759c344 (patch)
tree5ec47a640640bb77d3984a34b1870e16ce29ba5f /dev-python
parentdev-python/trimesh: Bump to 3.16.0 (diff)
downloadgentoo-599ef8110cc5ddd00e264445ded976377759c344.tar.gz
gentoo-599ef8110cc5ddd00e264445ded976377759c344.tar.bz2
gentoo-599ef8110cc5ddd00e264445ded976377759c344.zip
dev-python/gsd: Bump to 2.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gsd/Manifest1
-rw-r--r--dev-python/gsd/gsd-2.6.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/gsd/Manifest b/dev-python/gsd/Manifest
index f5b8da240349..be3e84713281 100644
--- a/dev-python/gsd/Manifest
+++ b/dev-python/gsd/Manifest
@@ -1,2 +1,3 @@
DIST gsd-v2.5.3.tar.gz 106104 BLAKE2B 39cadcca6a6660c736be8ce576b45d86a82a499bd21b6c818dcc6d307750940a8be85fdd63883d7aac9a416f5eddc55793ca2ab0da0b2373901c394d63ebe3f7 SHA512 3e3d5f8dece5553a4bc68b23aff8320b99169da5b995d1655da85c37e84a9e69d30f73ed3925e2e49b1c97dc875c594258dd15f3669337ca4c91914cab90d49c
DIST gsd-v2.6.0.tar.gz 105895 BLAKE2B d320829fb3a1d44feb637bf1c567908f74f0a0c82502b6af147921b547aca8fb0082cc185872398c5fbaefb6b797c0595ead9d1c8ce73ad3a72b961cb18f2a7f SHA512 968bdd0d2c3aeb993d0a91c3e69c17bcf8d8f0e6ff70cf3ff18655a87320cf522174e98996f5688ee205ac2ce2036b7cf7c1b4b21286a481ac21aa4a94ec38f6
+DIST gsd-v2.6.1.tar.gz 106134 BLAKE2B 2b2e54c9ee654f384340c642e52a9c154520490c48ec87b31a7186b2ccd494cf4918620c999456d03e128a0b36b588e4dc180904f5f553aef832e7e217e60a56 SHA512 732d291e410a47885449584bf09521398075e3074c4abe49301f07f4cb30a6841c2ddc8431d8aadbc4896f61cf32605b22422b7278da26827c303b4f6476e459
diff --git a/dev-python/gsd/gsd-2.6.1.ebuild b/dev-python/gsd/gsd-2.6.1.ebuild
new file mode 100644
index 000000000000..fd7b6e2d2c6e
--- /dev/null
+++ b/dev-python/gsd/gsd-2.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="
+ https://github.com/glotzerlab/gsd/
+ https://pypi.org/project/gsd/
+"
+SRC_URI="
+ https://github.com/glotzerlab/gsd/releases/download/v${PV}/${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-python/numpy-1.23.4[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gsd
+}