summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-26 15:12:12 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-26 15:12:12 +0100
commit69a11679a4133db3ea97b1103601ce857b0dc286 (patch)
treed89edb22890933542fdb318db0c52f96e9c9af6c /dev-python
parentdev-python/ml-dtypes: Remove old (diff)
downloadgentoo-69a11679a4133db3ea97b1103601ce857b0dc286.tar.gz
gentoo-69a11679a4133db3ea97b1103601ce857b0dc286.tar.bz2
gentoo-69a11679a4133db3ea97b1103601ce857b0dc286.zip
dev-python/mrcfile: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mrcfile/Manifest1
-rw-r--r--dev-python/mrcfile/files/mrcfile-1.4.3-test-assertion-error.patch25
-rw-r--r--dev-python/mrcfile/mrcfile-1.4.3.ebuild34
3 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/mrcfile/Manifest b/dev-python/mrcfile/Manifest
index 4486bbc70304..6cc2db5e4196 100644
--- a/dev-python/mrcfile/Manifest
+++ b/dev-python/mrcfile/Manifest
@@ -1,2 +1 @@
-DIST mrcfile-1.4.3.gh.tar.gz 148147024 BLAKE2B aa604965e6e40a25f57ec61bb3a3fc2fc6a83827db11620678138bec893539502a8e00e6e279e3bb86805773201338f430cc4d7d4b60efaee2d36933f071132e SHA512 e4bdc9b03ea55ae6bcaf29d8f8154e941f7e8b780f924a3265156a25bfa7f7a6f88abb3ce4374208104a4a3eea8d18724a248aae9fea2018a24ae559680ac2b7
DIST mrcfile-1.5.0.gh.tar.gz 148148453 BLAKE2B 45cb7483e0aa5d6a2ac4e077bd0e2a9a8a265c4fdb69fc467e1dd3bab79960478d69ed0ec5e4f97ff528a02255c1c0b3e839e808ff0380e7ea2926b569a5478f SHA512 90e85e74c413b74e9ea86996b9e1ed4ac8f8cc0e7537f1916482d5e89d1fa99814c23ad2e51d912485a02644eeb65925067190bb3a7b222310aca4946b037ecc
diff --git a/dev-python/mrcfile/files/mrcfile-1.4.3-test-assertion-error.patch b/dev-python/mrcfile/files/mrcfile-1.4.3-test-assertion-error.patch
deleted file mode 100644
index a68ffa562260..000000000000
--- a/dev-python/mrcfile/files/mrcfile-1.4.3-test-assertion-error.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From: Roland Mas <lolando@debian.org>
-Date: Tue, 14 Feb 2023 15:49:05 +0100
-Subject: Comment out a failing test
-
----
- tests/test_mrcobject.py | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/tests/test_mrcobject.py b/tests/test_mrcobject.py
-index 276e9af..95b5591 100644
---- a/tests/test_mrcobject.py
-+++ b/tests/test_mrcobject.py
-@@ -338,7 +338,11 @@ class MrcObjectTest(AssertRaisesRegexMixin, unittest.TestCase):
- def test_data_is_not_copied_unnecessarily(self):
- data = np.arange(6, dtype=np.int16).reshape(1, 2, 3)
- self.mrcobject.set_data(data)
-- assert self.mrcobject.data is data
-+ # Identity assertion fails with python3-numpy 1.24.2, so
-+ # replace with an equality assertion assert
-+ # This should be reverted eventually
-+ # self.mrcobject.data is data
-+ assert np.array_equal(self.mrcobject.data, data)
-
- def test_header_byte_order_is_unchanged_by_data_with_native_order(self):
- data = np.arange(6, dtype=np.float32).reshape(3, 2)
diff --git a/dev-python/mrcfile/mrcfile-1.4.3.ebuild b/dev-python/mrcfile/mrcfile-1.4.3.ebuild
deleted file mode 100644
index 48880b375bb0..000000000000
--- a/dev-python/mrcfile/mrcfile-1.4.3.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="MRC2014 file format I/O library"
-HOMEPAGE="
- https://pypi.org/project/mrcfile/
- https://github.com/ccpem/mrcfile/
-"
-SRC_URI="
- https://github.com/ccpem/mrcfile/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-RDEPEND="
- >=dev-python/numpy-1.16.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-
-PATCHES=(
- # https://github.com/ccpem/mrcfile/issues/49
- "${FILESDIR}/${P}-test-assertion-error.patch"
-)