summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-31 06:11:09 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-31 06:22:06 +0200
commit9026dd657179c63b3dc78871861bec196accdaf7 (patch)
tree4f0ef89fa57ba62167ecdae453eabe49446d3c60 /dev-python
parentdev-python/spotipy: Bump to 2.24.0 (diff)
downloadgentoo-9026dd657179c63b3dc78871861bec196accdaf7.tar.gz
gentoo-9026dd657179c63b3dc78871861bec196accdaf7.tar.bz2
gentoo-9026dd657179c63b3dc78871861bec196accdaf7.zip
dev-python/findimports: Bump to 2.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/findimports/Manifest1
-rw-r--r--dev-python/findimports/findimports-2.5.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/findimports/Manifest b/dev-python/findimports/Manifest
index dfe7f92f1b1e..89d5625bb736 100644
--- a/dev-python/findimports/Manifest
+++ b/dev-python/findimports/Manifest
@@ -1 +1,2 @@
DIST findimports-2.4.0.gh.tar.gz 26597 BLAKE2B 8dc176a551a07f38996ddbcf0df865ad7c7c1c7f86036be0939578a932155f30bdff17d2880063edd49ae1d169ebfb5bbade771a626859ad8306d54df743ee79 SHA512 90dfc39a5f73ea86a9d5c3ebec0f220f2f428f5768edc9688c47079f555b44abb80b4945b38550032289a3bff659f3857019a50882b1b2f2e83570f3e36530be
+DIST findimports-2.5.0.gh.tar.gz 26899 BLAKE2B 0050f0f711c3deb449993f8a50f484076005d5956275ba62ea55150c40b04540c3a2d656188da3d02775de71fc2d29f24b0855e91f160d491e384880b0b39043 SHA512 f75c9312c888fb456fe73983a2790f6e6841fd76692f7bce6e6d2e7c85e7055ee9d982af1b7cc8490de47dd2957ba1f74234698a519c36982dcb92bea6894301
diff --git a/dev-python/findimports/findimports-2.5.0.ebuild b/dev-python/findimports/findimports-2.5.0.ebuild
new file mode 100644
index 000000000000..100f1a16e168
--- /dev/null
+++ b/dev-python/findimports/findimports-2.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module import analysis tool"
+HOMEPAGE="
+ https://github.com/mgedmin/findimports/
+ https://pypi.org/project/findimports/
+"
+SRC_URI="
+ https://github.com/mgedmin/findimports/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" testsuite.py -v || die
+}