summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-03-08 12:03:14 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-03-08 14:06:01 +0100
commit92bf4d4d0d104e38a4465df4189eb1819e87c3d1 (patch)
tree0d603a2cdf4752c8f99fe8bc7b9977f2daf3b407 /dev-python
parentnet-print/cups-filters: Bump to version 1.20.1 (diff)
downloadgentoo-92bf4d4d0d104e38a4465df4189eb1819e87c3d1.tar.gz
gentoo-92bf4d4d0d104e38a4465df4189eb1819e87c3d1.tar.bz2
gentoo-92bf4d4d0d104e38a4465df4189eb1819e87c3d1.zip
dev-python/scandir: version bump to 1.7.
Package-Manager: Portage-2.3.19, Repoman-2.3.6 Closes: https://bugs.gentoo.org/649906 Closes: https://github.com/gentoo/gentoo/pull/7392
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/scandir/Manifest1
-rw-r--r--dev-python/scandir/scandir-1.7.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/scandir/Manifest b/dev-python/scandir/Manifest
index 4fa45382e684..dc0d5267b8d2 100644
--- a/dev-python/scandir/Manifest
+++ b/dev-python/scandir/Manifest
@@ -1,2 +1,3 @@
DIST scandir-1.5.tar.gz 29351 BLAKE2B 12cd7d18515ed597d0dc68ff435a442397a23691a0ad2d11d700f28b8abba58517859808190466fb799bb51a4757c4223fad0b1426c1be19bc1cd8f4ffd2601b SHA512 e6535e92011cc2c5f888ddd083a9dc48921609fd59d9bf9a4bcd596c055dc0510d48f6d3571605bbade3bd0e232e8bae94b44b20ba935e7ffdeec268ba3d2ee4
DIST scandir-1.6.tar.gz 29670 BLAKE2B ad8c231783c14246341cd23bd79185ee10894bb29107ba7c0bfdf51982bda99fd8ce45ea52ff42687371d56b3e6d43cf1d6cc65bdaecf43da9059e524a801e6d SHA512 d01e0551696787caded787a430eea787a69a27c725505277420fd607b3fcc892218377bb340651fd906bdeb3a57e99879df3c86aeadd2399fcbe45cb2118b9db
+DIST scandir-1.7.tar.gz 32812 BLAKE2B ed80775b5acca85d8829e2fb46df33fdda08d9dad6cc0e175d1270dc51b6eb4d381a5bd813e2dfd2072ac0af0d642d20ae818e569688ffbe5decaf4421f5e979 SHA512 47c6d9642938f374eb03228cdb6c8d77aa2af01a84b7efc518d223851562a615b616e92100bbeb38c4fa7455ef5f7ae4af8d406f5148d1a26a403708b4a27023
diff --git a/dev-python/scandir/scandir-1.7.ebuild b/dev-python/scandir/scandir-1.7.ebuild
new file mode 100644
index 000000000000..5b7b33f61fca
--- /dev/null
+++ b/dev-python/scandir/scandir-1.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A better directory iterator and faster os.walk()"
+HOMEPAGE="https://github.com/benhoyt/scandir"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} test/run_tests.py -v || die "tests failed under ${EPYTHON}"
+}