summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-06-06 20:39:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-06-06 20:39:17 +0300
commit9cc48229123637818ae4c7b39c987c2eb26a6b69 (patch)
tree61f2797d01331163c690c66ae0b01e3a46aa4948 /dev-python
parentdev-python/ConfigArgParse: enable py3.12 (diff)
downloadgentoo-9cc48229123637818ae4c7b39c987c2eb26a6b69.tar.gz
gentoo-9cc48229123637818ae4c7b39c987c2eb26a6b69.tar.bz2
gentoo-9cc48229123637818ae4c7b39c987c2eb26a6b69.zip
dev-python/pydiffx: enable py3.12
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pydiffx/files/pydiffx-1.1-fix-py3.12.patch14
-rw-r--r--dev-python/pydiffx/pydiffx-1.1.ebuild6
2 files changed, 19 insertions, 1 deletions
diff --git a/dev-python/pydiffx/files/pydiffx-1.1-fix-py3.12.patch b/dev-python/pydiffx/files/pydiffx-1.1-fix-py3.12.patch
new file mode 100644
index 000000000000..1be51cdb6c93
--- /dev/null
+++ b/dev-python/pydiffx/files/pydiffx-1.1-fix-py3.12.patch
@@ -0,0 +1,14 @@
+https://github.com/beanbaginc/diffx/pull/5
+From: Arthur Zamarin <arthurzam@gentoo.org>
+Date: Tue, 6 Jun 2023 20:32:44 +0300
+Subject: [PATCH] fix usage of deprecated assertRaisesRegex
+
+--- a/pydiffx/tests/testcases.py
++++ b/pydiffx/tests/testcases.py
+@@ -65,5 +65,5 @@ def assertMultiLineBytesEqual(self, first, second, line_endings='unix'):
+
+ @contextmanager
+ def assertRaisesMessage(self, exception, message):
+- with self.assertRaisesRegexp(exception, re.escape(message)):
++ with self.assertRaises(exception, msg=message):
+ yield
diff --git a/dev-python/pydiffx/pydiffx-1.1.ebuild b/dev-python/pydiffx/pydiffx-1.1.ebuild
index ec079b0ec93f..c35d375a1651 100644
--- a/dev-python/pydiffx/pydiffx-1.1.ebuild
+++ b/dev-python/pydiffx/pydiffx-1.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -34,6 +34,10 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-py3.12.patch
+)
+
distutils_enable_tests unittest
src_prepare() {