summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-27 04:31:20 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-27 04:53:47 +0200
commita119196411ab0080427edd8052cb6db88b35e73b (patch)
treee74da6958c57871281a94b2a01cd02ecd6a7844f /dev-python
parentdev-python/redis: Bump to 5.0.7 (diff)
downloadgentoo-a119196411ab0080427edd8052cb6db88b35e73b.tar.gz
gentoo-a119196411ab0080427edd8052cb6db88b35e73b.tar.bz2
gentoo-a119196411ab0080427edd8052cb6db88b35e73b.zip
dev-python/a2wsgi: Bump to 1.10.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/a2wsgi/Manifest1
-rw-r--r--dev-python/a2wsgi/a2wsgi-1.10.6.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/a2wsgi/Manifest b/dev-python/a2wsgi/Manifest
index 5a97b2513196..953a2f607798 100644
--- a/dev-python/a2wsgi/Manifest
+++ b/dev-python/a2wsgi/Manifest
@@ -1 +1,2 @@
DIST a2wsgi-1.10.4.tar.gz 18186 BLAKE2B 7f184c1621dd28e75c12e85b85ca4ed0b1b55d59c79797429bc188feec0ee0105e77c3613b1c2f94e1561f71fdcbabae99218e2c007ab095dd68b0502d112444 SHA512 6c050dcaca4dab0793afb267d7cbcb4faca362495c46ab9f0b52c9f2f5a1ab7dfd6fa0c543b5eaa18ddca6a789093591653f023ac9c127602138db390ae1c975
+DIST a2wsgi-1.10.6.tar.gz 18660 BLAKE2B 3f512bb37b03d7716559734e0653cdd7c7d77653495f15e8d172717016a3940e8e52a875321d675b3bfc4ebc41596d839a445ccb45c551d717e3f317b59aa955 SHA512 7b648865c759746520cf81502aabdcd9e19ddc1f270341d080d2422002f9e633be9ad837e06aef073a1d47ed4253b7e65eadbb1a76de89e571c498a5939c41a7
diff --git a/dev-python/a2wsgi/a2wsgi-1.10.6.ebuild b/dev-python/a2wsgi/a2wsgi-1.10.6.ebuild
new file mode 100644
index 000000000000..cb62c73b79f4
--- /dev/null
+++ b/dev-python/a2wsgi/a2wsgi-1.10.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Convert WSGI app to ASGI app or ASGI app to WSGI app"
+HOMEPAGE="
+ https://github.com/abersheeran/a2wsgi/
+ https://pypi.org/project/a2wsgi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ <dev-python/asgiref-4[${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.2.7[${PYTHON_USEDEP}]
+ <dev-python/httpx-1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires baize
+ tests/test_asgi.py::test_baize_stream_response
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio
+}