summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-24 15:01:13 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-24 15:01:13 +0200
commitaef86eada2ba23b8744957244fb2323d5724d469 (patch)
tree53bf1fe316f0f3756b1a5ce6a85e79fa956e1a06 /dev-python
parentdev-python/cfn-lint: Remove old (diff)
downloadgentoo-aef86eada2ba23b8744957244fb2323d5724d469.tar.gz
gentoo-aef86eada2ba23b8744957244fb2323d5724d469.tar.bz2
gentoo-aef86eada2ba23b8744957244fb2323d5724d469.zip
dev-python/transitions: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/transitions/Manifest1
-rw-r--r--dev-python/transitions/transitions-0.9.1.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/transitions/Manifest b/dev-python/transitions/Manifest
index 5ed1bd757a9d..0c1917a9b33a 100644
--- a/dev-python/transitions/Manifest
+++ b/dev-python/transitions/Manifest
@@ -1,2 +1 @@
-DIST transitions-0.9.1.gh.tar.gz 1124905 BLAKE2B 6d8700c9b2b2d200c8377e698f4057caa78908ee7156daa3fce1f49d86c6bc9afd45fe7af4122c2e124681c3c581e98f657e39444595f97ed7fb3c64f57d70fd SHA512 8e946ee9b8e3ed0629381514b4af4446625de0cea7cc8780326829ad987b4c0f9402484ed98ca66b12e95c8da79f77c62aba9f000dbe42779f158529cde3f279
DIST transitions-0.9.2.gh.tar.gz 1133297 BLAKE2B 9acb83355236941d49bbdc1877e352e1f86d2b95302455fc5ea2e13d9014f8e6c9dc67e04b70c03c40e3d10b9bcae97900420bfb7549decd7c2186284d9f7389 SHA512 7fa392b185b001b0224b449d65b345f71afa27f80a88d862456f637e5876644f09ca861ce8bd2ff93f91a7846e337a996f256645140a0892b526cd6c1f58ce7f
diff --git a/dev-python/transitions/transitions-0.9.1.ebuild b/dev-python/transitions/transitions-0.9.1.ebuild
deleted file mode 100644
index a353fdacea25..000000000000
--- a/dev-python/transitions/transitions-0.9.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517="setuptools"
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="A lightweight, object-oriented state machine implementation in Python"
-HOMEPAGE="https://github.com/pytransitions/transitions"
-SRC_URI="
- https://github.com/pytransitions/${PN}/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="examples"
-
-RDEPEND="
- || (
- dev-python/pygraphviz[${PYTHON_USEDEP}]
- dev-python/graphviz[${PYTHON_USEDEP}]
- )
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/dill[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # magic to ignore async tests sometimes, breaks EPYTEST_IGNORE
- [[ ${PV} != 0.9.1 ]] && die "Remove this hack"
- rm conftest.py || die
-}
-
-python_test() {
- local EPYTEST_IGNORE=(
- # pycodestyle, mypy, etc.
- tests/test_codestyle.py
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-src_install() {
- distutils-r1_src_install
- use examples && dodoc examples/*.ipynb
-}