summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-03-15 16:21:47 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-03-16 17:45:22 -0700
commitb14a8a24536e497d2a113ef4ecc82a08c50c7874 (patch)
tree3d3cd348887835ae269b3bd42648d0b9aee56d09 /dev-python
parentdev-python/pytest-shutil: Version bump (diff)
downloadgentoo-b14a8a24536e497d2a113ef4ecc82a08c50c7874.tar.gz
gentoo-b14a8a24536e497d2a113ef4ecc82a08c50c7874.tar.bz2
gentoo-b14a8a24536e497d2a113ef4ecc82a08c50c7874.zip
dev-python/pytest-virtualenv: Version bump
Package-Manager: Portage-2.3.4_p1, Repoman-2.3.2_p2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-virtualenv/Manifest1
-rw-r--r--dev-python/pytest-virtualenv/pytest-virtualenv-1.2.7.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-virtualenv/Manifest b/dev-python/pytest-virtualenv/Manifest
index 4dbf3de40725..f321bea29504 100644
--- a/dev-python/pytest-virtualenv/Manifest
+++ b/dev-python/pytest-virtualenv/Manifest
@@ -1 +1,2 @@
DIST pytest-virtualenv-1.2.5.tar.gz 9480 SHA256 ecd883d6bc9cd70f66b4297dfb0d04415b013cdc3efb8b8a0b917a516b50d22e SHA512 7d437346c3b4aa96078cc4fa8f0b6c83b173572209e71a74c77098ab4e8ad0c571c0932c2b413123cd73f47a4eda36d0c0ae3ece2866afc2d1f5092357c7593a WHIRLPOOL f3fb869b85a5d582afbd297c3dedee6f864e53efcbc11cd5d199649fb0df048ac42f17a25ac2aff1c0c876ccb664361cb6b57865a143899a3d6c75cf6817fbb5
+DIST pytest-virtualenv-1.2.7.tar.gz 9836 SHA256 51fb6468670624b2315aecaf1a2bbd698509e3ea6a1e28b094984c45e1376755 SHA512 046bfe20a08f6081c21a01bb4137b0bb481fddb61ac2cbf1a764dfec1eccf7393236e4358fdfdb5e982aba01cf3ac457c4320c2f56fa542542dd9721403bf9ec WHIRLPOOL 183fe45480c84dadbd34006c92c3d72220ff3e0321781013ff829ad2392963be5d17316a17719bcdd92f51407d7433f73380d3300f631f75fcd354a7b58b2411
diff --git a/dev-python/pytest-virtualenv/pytest-virtualenv-1.2.7.ebuild b/dev-python/pytest-virtualenv/pytest-virtualenv-1.2.7.ebuild
new file mode 100644
index 000000000000..3cb43868cace
--- /dev/null
+++ b/dev-python/pytest-virtualenv/pytest-virtualenv-1.2.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtualenv fixture for py.test"
+HOMEPAGE="https://github.com/manahl/pytest-plugins https://pypi.python.org/pypi/pytest-virtualenv"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-shutil[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}