summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-27 10:04:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-27 11:51:31 +0100
commitb26f6bf044e8b90e4f6db94b944423d03b81902c (patch)
tree49604f8d8744eac6b184880b48572a82d1963507 /dev-python
parentdev-python/nbclassic: Bump to 0.5.1 (diff)
downloadgentoo-b26f6bf044e8b90e4f6db94b944423d03b81902c.tar.gz
gentoo-b26f6bf044e8b90e4f6db94b944423d03b81902c.tar.bz2
gentoo-b26f6bf044e8b90e4f6db94b944423d03b81902c.zip
dev-python/Nuitka: Bump to 1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Nuitka/Manifest1
-rw-r--r--dev-python/Nuitka/Nuitka-1.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index 042360365712..dae6ce57206a 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,2 +1,3 @@
DIST Nuitka-1.3.7.tar.gz 4029412 BLAKE2B daa123ff224d442bc5afe251cf2658945a8cf7ca2c173307da81a72cf915c7110958bb7650b9bc2d3ff98f6867530554125b37d3f1e30d5bd784f648e8da785d SHA512 afff1e77bdce22ce41ca0d9824392f2319ab7b9754d26a00f6001bab09402d8f8665a921077d4e08958e4508fb922c833e4c16d25a04da6925a84a96cee0a87c
DIST Nuitka-1.3.8.tar.gz 4030106 BLAKE2B 5e762b2dde0d86f8dd78bee101ee3492468a628468c485d06759c2c1e6829f647e429122227425806c7063c5071968a73ce24865e957db67465726d42796070c SHA512 34f5b6e9f859ed194b5928bad3b6042fdccd9d798dfc0cbed9bcbb623a093ee700adbfd2887c1322703d69494a4ffae556c7cadb4b4b0178990867f3693bdd35
+DIST Nuitka-1.4.tar.gz 4121399 BLAKE2B 6f431ce01e5efc18cb71fffa8d4db1479adaab48f91c5943fe97d9252dd80ec6a875e0fbc480b13b38167534254a9fb589664d7d95b7e679b22e3c4ef27f5a5a SHA512 cc07b8c35e75c3d34566d335e27789900095c35bf411e284c262f7a85f54ee9922b8f2aa0a75e72e2b77559f594183ea84aeba5691e600181fc706680bb55136
diff --git a/dev-python/Nuitka/Nuitka-1.4.ebuild b/dev-python/Nuitka/Nuitka-1.4.ebuild
new file mode 100644
index 000000000000..3ad289dde538
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-1.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}