summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-13 22:02:58 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-13 22:31:09 +0200
commitb7203f05e0482ac749fe859241a6a402757e4ef7 (patch)
tree40fffa8e6fca330228e867b1fd312ce9810e1f09 /dev-python
parentapp-admin/awscli: Bump to 1.20.41 (diff)
downloadgentoo-b7203f05e0482ac749fe859241a6a402757e4ef7.tar.gz
gentoo-b7203f05e0482ac749fe859241a6a402757e4ef7.tar.bz2
gentoo-b7203f05e0482ac749fe859241a6a402757e4ef7.zip
dev-python/sphinx_rtd_theme: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx_rtd_theme/Manifest1
-rw-r--r--dev-python/sphinx_rtd_theme/sphinx_rtd_theme-1.0.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/sphinx_rtd_theme/Manifest b/dev-python/sphinx_rtd_theme/Manifest
index 24daf3d45d6b..37d58481f12a 100644
--- a/dev-python/sphinx_rtd_theme/Manifest
+++ b/dev-python/sphinx_rtd_theme/Manifest
@@ -1 +1,2 @@
DIST sphinx_rtd_theme-0.5.2.tar.gz 7606638 BLAKE2B c104121b36c89f4d2b7c2fc12433ffd1a7cba9b9d532358dafd53061b2ca9ead4bb93b7b596394c244a9da51c0b9299f2fe0ec8d4ca102015b6c7dfb92081813 SHA512 dd46bfeb05b433970d8130c06cad6dfa9dbc4e9db2d9a8190b80232d75b4d0a86590c17d64b9b1dcd2cb1d042033f4d2c2ce2e5cac0239c6b86899628b94b274
+DIST sphinx_rtd_theme-1.0.0.tar.gz 2780623 BLAKE2B 02e72ddade0632423d21e512ab86fbdcc9f18eddbef328ba766f1b06a49c838808af4ee000e57c8f0f40112569b35c1b62c9c0c8853c237fd2ddb6de76d48a21 SHA512 06025445e1358c994bf0c15a382ec8f8f3f2114dfac19f340585a3660d91a279100c2d16ef665d9eb8d38b0e4ed264e96d3ac6814dd01b9430d2f8a0d8275178
diff --git a/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-1.0.0.ebuild b/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-1.0.0.ebuild
new file mode 100644
index 000000000000..18cb43fd10f7
--- /dev/null
+++ b/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="ReadTheDocs.org theme for Sphinx"
+HOMEPAGE="https://github.com/readthedocs/sphinx_rtd_theme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE=""
+
+PDEPEND=">=dev-python/sphinx-1.6[${PYTHON_USEDEP}]"
+RDEPEND="<dev-python/docutils-0.18[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ dev-python/readthedocs-sphinx-ext[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # CI=1 disables rebuilding webpack that requires npm use
+ # yes, that surely makes sense
+ export CI=1
+}