summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-19 08:22:18 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-19 08:34:07 +0200
commitbc3e7e704bdc8d02e870a29b6e81d500fbba35d0 (patch)
tree19e7d2ab18c2776f2ea3f0b3459ba821a7c69d3c /dev-python
parentdev-python/importlib_metadata: Bump to 6.5.0 (diff)
downloadgentoo-bc3e7e704bdc8d02e870a29b6e81d500fbba35d0.tar.gz
gentoo-bc3e7e704bdc8d02e870a29b6e81d500fbba35d0.tar.bz2
gentoo-bc3e7e704bdc8d02e870a29b6e81d500fbba35d0.zip
dev-python/google-api-python-client: Bump to 2.86.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.86.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 794c14a746b7..bb87caea0410 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -3,3 +3,4 @@ DIST google-api-python-client-2.82.0.tar.gz 10656632 BLAKE2B c94f96c727f7d0cacf0
DIST google-api-python-client-2.83.0.tar.gz 10684846 BLAKE2B 82c8c563c2f78584d0a98ac433972ac52a38a69aa5b2eb16941372260045d9a40fd6b7ee04210824bc847fb0902f46a9d0ba376056dab16202d121dd50ca4c38 SHA512 bc05ef744aa13405c41348233d111d3f34882b30b8ef1edf9581ff96d913717bdc2281d29b28eda7119c04dba7ec133cada9b1750f159aa8d9c125cfd707881d
DIST google-api-python-client-2.84.0.tar.gz 10727897 BLAKE2B 620a24b0a887eb92116dd8b804e2164cfdfb3215ac441de2db0b9de4f489591fb494c9cf869afef9b5e2c27f893acbfd2723a3b1f7587020bded0d76e078f5c1 SHA512 4b29e41500cafc033b7ef41bb345798ded595a2638cf49219285709d3a90431b9fb6ba1c473ffcb4e54f5f4da7e229f6735dd1a3ac156991bfd129da48ab2853
DIST google-api-python-client-2.85.0.tar.gz 10747605 BLAKE2B 832017bbd4427a70c6c3dcce215a1e23442eb5c5bed069261da1ec85ed7ac838cea530e45f794c6142beb40b188d685cf47b6a96bd8e959421d2f8edd504b736 SHA512 491fffc8911361fc69b9490e0615046668c07d4d878c16a50ca4f0bed9f0815fa14cc34930d3a1c47a54f6f32de584ef7617fadb8f0a4b6ca92cd11926b35952
+DIST google-api-python-client-2.86.0.tar.gz 10767816 BLAKE2B 532b86d49dfec724237a07c6d6c4dccbdf7a4f9d8c6a1c7f96548708c55e5851bca3e1f0f28da65edbde68a6d760498af8936be177ce5c0dda3e6809db218188 SHA512 2d1aea4a6735aeffbc4aba05affaa3c4389e2f9f121185d5a5d47e818e33ae3506bebf2748d7a14b374310531c7c3a34325524c5c48df3c882c6b2a4ce579e8d
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.86.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.86.0.ebuild
new file mode 100644
index 000000000000..0194f9640998
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.86.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}