summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-30 19:43:33 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-30 19:51:28 +0200
commitc4373093723cf702859e4e0b07f2a4a46d12dadc (patch)
tree357459c81c38b2a0f1aa2978bbfccb4535f01df1 /dev-python
parentdev-python/xxhash: Bump to 3.3.0 (diff)
downloadgentoo-c4373093723cf702859e4e0b07f2a4a46d12dadc.tar.gz
gentoo-c4373093723cf702859e4e0b07f2a4a46d12dadc.tar.bz2
gentoo-c4373093723cf702859e4e0b07f2a4a46d12dadc.zip
dev-python/pytest-param-files: Bump to 0.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-param-files/Manifest1
-rw-r--r--dev-python/pytest-param-files/pytest-param-files-0.6.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pytest-param-files/Manifest b/dev-python/pytest-param-files/Manifest
index de95dc54aaee..241be20b3dfa 100644
--- a/dev-python/pytest-param-files/Manifest
+++ b/dev-python/pytest-param-files/Manifest
@@ -1,2 +1,3 @@
DIST pytest-param-files-0.3.5.gh.tar.gz 7245 BLAKE2B 2a67c5ee30d6efb6b7ca7e3272c19c05dda460167cb1709693560ffe06b0ae39ae1b93fc5d6375f4e9cda21e3e02051424789afee55d201cfe070be8a05642ec SHA512 e80eddba2934fe5a6b68645cae243afa936ea3362a29d0b8a8ae4e11229ffb877f1ace9f41ac96d182d5787740fa76af8b106069feb95a7cab1ecc6f8d1088f9
DIST pytest-param-files-0.5.0.gh.tar.gz 8563 BLAKE2B fa3907f3da7607caa3ab4933052ce70bc87bdf1b55983ef9660dbf0d6ae8a838d185be7f03f8ee5a1beb5771bb9f19f46fc012eea1eb7ca6331ba3c9626c72ca SHA512 cfff7ef20d453cf50a72e78d546a948d49c415c212ffba8e0ac4abe1da2decd9097930777b5aa182fb97c9c5c01e4b00bee25bd27f34c6f35a14ba7177d17a16
+DIST pytest-param-files-0.6.0.gh.tar.gz 8526 BLAKE2B be4f2f385d5dcbb1debde45a9fb48cb22c8e75e39daeaf891ca2b0321afbd27b4917b1f6058816e9fac2fb589076a06d6159bbbb0bac610bc3498ffcf71cf812 SHA512 712e4dfcccec3bc266f98a6339985b42171cf255552356107953dba691f4d6cfac125a8390349459cf67d8ca92ddc2a9dba8cfdd9b3a20a5ec6578df93cb006a
diff --git a/dev-python/pytest-param-files/pytest-param-files-0.6.0.ebuild b/dev-python/pytest-param-files/pytest-param-files-0.6.0.ebuild
new file mode 100644
index 000000000000..56a3121eaa66
--- /dev/null
+++ b/dev-python/pytest-param-files/pytest-param-files-0.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest parametrize decorators from external files."
+HOMEPAGE="
+ https://github.com/chrisjsewell/pytest-param-files/
+ https://pypi.org/project/pytest_param_files/
+"
+SRC_URI="
+ https://github.com/chrisjsewell/pytest-param-files/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.15[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest