summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-16 05:20:11 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-16 06:04:15 +0100
commite5a928255b6d235ae66f2e71c65f93e7f8c4c9d7 (patch)
tree5b6d794f03b06f11d34bcf7bfcaa272af0019701 /dev-python
parentapp-admin/awscli: Bump to 1.27.72 (diff)
downloadgentoo-e5a928255b6d235ae66f2e71c65f93e7f8c4c9d7.tar.gz
gentoo-e5a928255b6d235ae66f2e71c65f93e7f8c4c9d7.tar.bz2
gentoo-e5a928255b6d235ae66f2e71c65f93e7f8c4c9d7.zip
dev-python/pytest-subtests: Bump to 0.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-subtests/Manifest1
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.10.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
index a6a2ac1af939..232680627d04 100644
--- a/dev-python/pytest-subtests/Manifest
+++ b/dev-python/pytest-subtests/Manifest
@@ -1 +1,2 @@
+DIST pytest-subtests-0.10.0.gh.tar.gz 10253 BLAKE2B dba434dfc3f27293d5576ad408665917394ff54d41aef5604f40d787c4d7d9c6fc42b99ca10a8d46707fc8ce0eb5aab8e27bb32b464f5c9350f6bda6b12df031 SHA512 2fc3f8316db879d64d4dd4ad53df7dbda30b69df9291608eb6235aa27e9e6b3ec4174023f9ffa016811eb8955f0ebd673ead7b7319d927d18d7c016e0c7ef573
DIST pytest-subtests-0.9.0.gh.tar.gz 9840 BLAKE2B c94155c1e44b4bf81bc4d2d1963c952b721634372db9dc5c1b8a7819acba8e84815333c0c67a90d2a930abb98affbd99a721796ed09513635923f6a89e336d4a SHA512 f1bc2b99e6f04864cdc45675574d32821fd5e08c01c937bddc846ac509cd8906d21ee63b11e9e8a87c2631334541e9adc601a7dd69702572d51c3d4b72443ad2
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.10.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.10.0.ebuild
new file mode 100644
index 000000000000..82a381512d9d
--- /dev/null
+++ b/dev-python/pytest-subtests/pytest-subtests-0.10.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="unittest subTest() support and subtests fixture"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-subtests/
+ https://pypi.org/project/pytest-subtests/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-subtests/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7[${PYTHON_USEDEP}]
+"
+# pytest-xdist is used to test compatibility
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked,pytest_subtests
+ epytest
+}