summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-24 04:11:53 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-24 04:41:05 +0200
commite7aeb7d77a48ea4592b12afbe7be93a4f2d62d99 (patch)
tree80abc61f2e0c60ed8fad821fbc1a39b7a4c1c228 /dev-python
parentdev-python/hishel: Bump to 0.0.29 (diff)
downloadgentoo-e7aeb7d77a48ea4592b12afbe7be93a4f2d62d99.tar.gz
gentoo-e7aeb7d77a48ea4592b12afbe7be93a4f2d62d99.tar.bz2
gentoo-e7aeb7d77a48ea4592b12afbe7be93a4f2d62d99.zip
dev-python/pyftpdlib: Bump to 1.5.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyftpdlib/Manifest1
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.10.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pyftpdlib/Manifest b/dev-python/pyftpdlib/Manifest
index 187310993d85..5b5aec456260 100644
--- a/dev-python/pyftpdlib/Manifest
+++ b/dev-python/pyftpdlib/Manifest
@@ -1 +1,2 @@
+DIST pyftpdlib-1.5.10.tar.gz 204487 BLAKE2B 7c611498dc2d11f752bf6a0ada01d906fca5c28e93b21bbcaaa76fafc88dcfe7afe616eb06f102123e614e061db2b6b62766f5036d749f8bd2b6d5cc35fc52e8 SHA512 c8c28d7aab13f2aab222ae038bde96f17abefd461830813ca00b621a6ee3e809c59ed135149ba735e7e92a6722aecfaf7095ccbacd7b3e17a16ee69fe1668766
DIST pyftpdlib-1.5.9.tar.gz 204755 BLAKE2B f96e670a37023489a3f70f28d7e489633031f4c8dd34e6ece04a13a36a5de60f216dc267a80650c3f315a6a83081b1afc1b470c75ca18af5a80729a7ac363b98 SHA512 3efa07f5522cee89d2bf60c93b1315dfb149da622f34e043aca0ac1c4336c0a0885d7238123068401afa6988da9cbde6adfac78f08918d3a14e84c17ebb8b32f
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.10.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.10.ebuild
new file mode 100644
index 000000000000..2016e5ca927f
--- /dev/null
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.10.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python FTP server library"
+HOMEPAGE="
+ https://github.com/giampaolo/pyftpdlib/
+ https://pypi.org/project/pyftpdlib/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples ssl"
+
+RDEPEND="
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+python_test() {
+ rm -rf pyftpdlib || die
+ # Some of these tests tend to fail
+ local EPYTEST_DESELECT=(
+ # fail because they process sys.argv and expect program args
+ # rather than pytest args, sigh
+ test/test_misc.py
+ # TODO
+ test/test_functional_ssl.py::TestFtpListingCmdsTLSMixin::test_nlst
+ )
+ # Tests fail with TZ=GMT, see https://bugs.gentoo.org/666623
+ local -x TZ=UTC+1
+ # Skips some shoddy tests plus increases timeouts
+ local -x TRAVIS=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest --pyargs pyftpdlib
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r demo/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}