summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-29 00:32:41 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-01 11:31:51 +0100
commite9113127007ce9ee73df9bfc3a10032d30fc093b (patch)
tree5098e86fddd6aa85d526a592d5476e2c7a869b78 /dev-python
parentdistutils-r1.eclass: Introduce install_for_testing --via-root (diff)
downloadgentoo-e9113127007ce9ee73df9bfc3a10032d30fc093b.tar.gz
gentoo-e9113127007ce9ee73df9bfc3a10032d30fc093b.tar.bz2
gentoo-e9113127007ce9ee73df9bfc3a10032d30fc093b.zip
dev-python/hypothesis: Use dift --via-root API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/hypothesis-5.41.4.ebuild6
1 files changed, 1 insertions, 5 deletions
diff --git a/dev-python/hypothesis/hypothesis-5.41.4.ebuild b/dev-python/hypothesis/hypothesis-5.41.4.ebuild
index 30e83a217730..7cd8e4bcc527 100644
--- a/dev-python/hypothesis/hypothesis-5.41.4.ebuild
+++ b/dev-python/hypothesis/hypothesis-5.41.4.ebuild
@@ -48,11 +48,7 @@ python_prepare() {
}
python_test() {
- local -x PYTHONPATH="${BUILD_DIR}/install/lib"
- esetup.py install \
- --root="${BUILD_DIR}/install" \
- --install-lib=lib
-
+ distutils_install_for_testing --via-root
pytest -vv tests/cover tests/pytest tests/quality \
-n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
die "Tests fail with ${EPYTHON}"