summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-03 04:33:55 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-03 04:36:56 +0100
commitf6f5efaf0da682ed1debec2295405b63131bbc43 (patch)
treeb767a5d4158b63325daf79d4668bb21c248a8035 /dev-python
parentdev-python/simpleeval: Bump to 1.0.3 (diff)
downloadgentoo-f6f5efaf0da682ed1debec2295405b63131bbc43.tar.gz
gentoo-f6f5efaf0da682ed1debec2295405b63131bbc43.tar.bz2
gentoo-f6f5efaf0da682ed1debec2295405b63131bbc43.zip
dev-python/pulsectl-asyncio: Bump to 1.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pulsectl-asyncio/Manifest1
-rw-r--r--dev-python/pulsectl-asyncio/pulsectl-asyncio-1.2.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pulsectl-asyncio/Manifest b/dev-python/pulsectl-asyncio/Manifest
index fc382ce246b7..6ee8803cbfff 100644
--- a/dev-python/pulsectl-asyncio/Manifest
+++ b/dev-python/pulsectl-asyncio/Manifest
@@ -1 +1,2 @@
DIST pulsectl-asyncio-1.2.1.gh.tar.gz 19531 BLAKE2B 4a3275d75602907f91b3a0979ff8908f4fa23bcf5d1d04068f878fc477011258180cec8ef16b6e6ebe6cc1713ff493841686cc67c4990222c061aa1b722199ff SHA512 b22d0a634433d558860ff1590020ba7272412be97da478a8b00ec457506cb58353b645537ae26591f1aed300cacc14fd0f50c8a3a0c7d650d610b24cc52248ee
+DIST pulsectl-asyncio-1.2.2.gh.tar.gz 19528 BLAKE2B 8b4ccf8a1509fddff19cf201dc9ff4cbf03aedc2ab47c6f4920f95072706051a0a9ab3704e4a4650be8ebce67682bff28d8dacdfac272c36019810eea358f01f SHA512 ccaa7ae14fd2ca7e9d6483efcb3d48f8364ed87ab99c700323c2f2d803986408394ae0fe83880d4d77b77daf17dfb58c6e9f94043a9b03ad643bff2e909a673a
diff --git a/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.2.2.ebuild b/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.2.2.ebuild
new file mode 100644
index 000000000000..8b6cfcbfc7dc
--- /dev/null
+++ b/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.2.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Asyncio frontend for pulsectl, Python bindings of libpulse"
+HOMEPAGE="
+ https://github.com/mhthies/pulsectl-asyncio/
+ https://pypi.org/project/pulsectl-asyncio/
+"
+# sdist is missing examples that are used in tests
+SRC_URI="
+ https://github.com/mhthies/pulsectl-asyncio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pulsectl-23.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ media-sound/pulseaudio-daemon
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e 's:,<=[0-9.]*::' setup.cfg || die
+ distutils-r1_src_prepare
+}