summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-06 09:25:20 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-06 11:58:59 +0100
commitf918fa062393aea9bc08731e36b4c06610c12114 (patch)
treef4c5c1fab12a4e3f88dc244437cebe686450c4c9 /dev-python
parentdev-python/xarray: Bump to 0.20.1 (diff)
downloadgentoo-f918fa062393aea9bc08731e36b4c06610c12114.tar.gz
gentoo-f918fa062393aea9bc08731e36b4c06610c12114.tar.bz2
gentoo-f918fa062393aea9bc08731e36b4c06610c12114.zip
dev-python/jsonschema: Bump to 4.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jsonschema/Manifest1
-rw-r--r--dev-python/jsonschema/jsonschema-4.2.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index 31b50ee5497a..94eba716f4f1 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -4,3 +4,4 @@ DIST jsonschema-4.1.0.tar.gz 306755 BLAKE2B a98f1050943543ac51a2e0a7242a8bab9098
DIST jsonschema-4.1.1.tar.gz 310026 BLAKE2B c14bee88d20c53e4198e58b946c92a5c505a205daa09c30c474c2e95af45414b1c527298a2e0df647acd79ccbe9344c2aa03ee3e1b7daafda76153248e73f794 SHA512 7afa1bffd9631a503277479595cc9ed9a58ecd0f8f9035a2b65e4005f9f58ff4f6fa968b5ca783aa22c4530fc4acc5e2ea1ef2f67b7f4f09f245e9a6f2b2c3bd
DIST jsonschema-4.1.2.tar.gz 310016 BLAKE2B 16ec4f73a16980ec69e4c8e0d937726a6fcbf7ba0ba24dc9d76b5bf107b924fb3917927748e3dafacc0305322e9cb405daa83800dcfd5f2fcc63dbb8fe10a25a SHA512 5ab43602cfc2dfe07a8c733f01915b4961ee88ebb37723a7a3a6ee4793ddae4b4638abe77ac9d192158ae7634aacee0c58fa2959288ea0f83e3403d5f8b9f185
DIST jsonschema-4.2.0.tar.gz 310667 BLAKE2B 6210d1be3c4d72a9b5677fd06754df1b7d25ca6f0e7eb54089e0783e32408baf5f233a2a75eec686dddc7d112e397769ab58b0d1ac2d6246806375ed09427122 SHA512 75837145f542e8cf112b40e5fc5ec573bec8dfc6a27e9a7a4de6fbf127d845736509f89188700d68fe585ddf75f8e8a6e1d5c569e89bd8c03b36258adf36dab8
+DIST jsonschema-4.2.1.tar.gz 310668 BLAKE2B ba36be8abf0678fda773a9950f06e4d15f6a4c19fdd9f855310b80f45be1a25f44ce329c35667c4e107aab6ba381b02ff2caa305222932e2cbe733f293de82cc SHA512 349993c00e663f3efa2304e60c8b75e90c012d29faa498a01d5d2a5c47ddf0485f28894fd2ddf4766f9ab91e468f4b4f24a53390c72b7a31fae37d75c6f2b774
diff --git a/dev-python/jsonschema/jsonschema-4.2.1.ebuild b/dev-python/jsonschema/jsonschema-4.2.1.ebuild
new file mode 100644
index 000000000000..ff7d016261dd
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-4.2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="https://pypi.org/project/jsonschema/ https://github.com/Julian/jsonschema"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/pyrsistent-0.18.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' pypy3)
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-1.4.0[${PYTHON_USEDEP}]
+ ' pypy3 python3_8)
+"
+
+# formatter deps
+RDEPEND+="
+ dev-python/fqdn[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/isoduration[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/uritemplate[${PYTHON_USEDEP}]
+ >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+)