summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2018-03-13 01:01:22 +0000
committerBrian Dolbec <dolsen@gentoo.org>2018-03-13 23:56:33 +0000
commitfebd86d19c138d94e7fdc310728ac91b1ce42ad1 (patch)
treede81a00f937195b00e3f94ba7086846c2cb02413 /dev-python
parentnet-misc/crossbar: Version bump (diff)
downloadgentoo-febd86d19c138d94e7fdc310728ac91b1ce42ad1.tar.gz
gentoo-febd86d19c138d94e7fdc310728ac91b1ce42ad1.tar.bz2
gentoo-febd86d19c138d94e7fdc310728ac91b1ce42ad1.zip
dev-python/jira: Version bump
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jira/Manifest1
-rw-r--r--dev-python/jira/jira-1.0.14.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/jira/Manifest b/dev-python/jira/Manifest
index 2d7898392a24..8bda5f7f8d07 100644
--- a/dev-python/jira/Manifest
+++ b/dev-python/jira/Manifest
@@ -1,2 +1,3 @@
DIST jira-1.0.10.tar.gz 98406 BLAKE2B a030a9636fa787d05e3455d2942bab35f866a24790ee34ab0822b437ce911f3500d8aeceeff66ba642dccff27ab9307b8e7ebb3af6a7d805279afd7c27e8ac7f SHA512 5b6bf3ae04d50a2a1f45cbd57f4bc3aabb3d9524b582d55c5a5b39ac9128de15c78e463234dce13cb60d18d8ee36a5844ecc1681978276c8f0fd66ae16ca4195
+DIST jira-1.0.14.tar.gz 151627 BLAKE2B 018d6a2a3fc782254c6c1b67adbc01e045e748ed341a7f93d3fc9546e25a083b931747fb9160ddd7e7f1b0a2f8992d25980dd647222c2b55ef8a1c9813f399f3 SHA512 baa5a1bfe60147771643c544f1dadbf28c66124da34fe907e5e8daf48ad8edeae0730f255e811c4de377a18883083a31efedc33dcf09b8875b9f018bbf65b5b7
DIST jira-1.0.5.tar.gz 113738 BLAKE2B 056ec99ace00b03f4068cb400d3e99135356ccee0bbd53cdb16e776496056fdcdf828eb5956622359caa899967cda239f05a5d9a8831047a09d56c1c06edd96c SHA512 e84e96813b672f57f85613da5a0e9e960e191cf8037146b6f80229563a544839ab3b650894064d29ed22db1bd022ef401e693e3b20aaf8c58cb525b2614edab6
diff --git a/dev-python/jira/jira-1.0.14.ebuild b/dev-python/jira/jira-1.0.14.ebuild
new file mode 100644
index 000000000000..08a583cdb83e
--- /dev/null
+++ b/dev-python/jira/jira-1.0.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Python library for interacting with the JIRA REST API"
+HOMEPAGE="https://jira.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="filemagic ipython oauth"
+
+DEPEND="
+ >=dev-python/pbr-3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ filemagic? ( dev-python/filemagic[${PYTHON_USEDEP}] )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
+ oauth? (
+ || ( dev-python/pycryptodome[${PYTHON_USEDEP}] dev-python/pycrypto[${PYTHON_USEDEP}] )
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ )
+ "