summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-15 10:37:11 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-15 10:39:06 +0100
commitff1653aa82e8fb777a7f971b519c75b0cb074ee1 (patch)
treeb899a7f402a9e5b6cd5e46134b0def1ce3bc3592 /dev-python
parentdev-python/pygame: Use PEP517 build (diff)
downloadgentoo-ff1653aa82e8fb777a7f971b519c75b0cb074ee1.tar.gz
gentoo-ff1653aa82e8fb777a7f971b519c75b0cb074ee1.tar.bz2
gentoo-ff1653aa82e8fb777a7f971b519c75b0cb074ee1.zip
dev-python/python-dotenv: Fix installing entry points
Closes: https://bugs.gentoo.org/833389 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-dotenv/files/python-dotenv-0.19.2-entry-points.patch21
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.19.2-r1.ebuild (renamed from dev-python/python-dotenv/python-dotenv-0.19.2.ebuild)8
2 files changed, 27 insertions, 2 deletions
diff --git a/dev-python/python-dotenv/files/python-dotenv-0.19.2-entry-points.patch b/dev-python/python-dotenv/files/python-dotenv-0.19.2-entry-points.patch
new file mode 100644
index 000000000000..a01806fbc8c1
--- /dev/null
+++ b/dev-python/python-dotenv/files/python-dotenv-0.19.2-entry-points.patch
@@ -0,0 +1,21 @@
+diff --git a/setup.py b/setup.py
+index a8122d3..c7bfe82 100644
+--- a/setup.py
++++ b/setup.py
+@@ -36,10 +36,12 @@ setup(
+ extras_require={
+ 'cli': ['click>=5.0', ],
+ },
+- entry_points='''
+- [console_scripts]
+- dotenv=dotenv.cli:cli
+- ''',
++ entry_points={
++ "console_scripts": [
++ "dotenv=dotenv.cli:cli",
++ "python-dotenv=dotenv.cli:cli",
++ ],
++ },
+ license='BSD-3-Clause',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
diff --git a/dev-python/python-dotenv/python-dotenv-0.19.2.ebuild b/dev-python/python-dotenv/python-dotenv-0.19.2-r1.ebuild
index 662c99d941fc..066098d96dfe 100644
--- a/dev-python/python-dotenv/python-dotenv-0.19.2.ebuild
+++ b/dev-python/python-dotenv/python-dotenv-0.19.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -25,7 +25,11 @@ DEPEND="
DOCS=( CHANGELOG.md README.md )
PATCHES=(
- "${FILESDIR}"/${PN}-0.18.0-second-entrypoint.patch # bug 798648
+ # rename the entry point (note: old name is needed in tests)
+ # https://bugs.gentoo.org/798648
+ # also fix syntax since it doesn't seem to work anymore
+ # https://bugs.gentoo.org/833389
+ "${FILESDIR}"/python-dotenv-0.19.2-entry-points.patch
)
distutils_enable_tests --install pytest