summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-11 06:48:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-11 07:18:03 +0200
commitff37cff7fc29da1ba6967ba5b19b3daff3ee8eaa (patch)
treecdb40db51e3dfe533a6be7e3f22b53fe11c7b55a /dev-python
parentdev-python/sphinx-autoapi: Bump to 2.1.1 (diff)
downloadgentoo-ff37cff7fc29da1ba6967ba5b19b3daff3ee8eaa.tar.gz
gentoo-ff37cff7fc29da1ba6967ba5b19b3daff3ee8eaa.tar.bz2
gentoo-ff37cff7fc29da1ba6967ba5b19b3daff3ee8eaa.zip
dev-python/tempora: Bump to 5.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tempora/Manifest1
-rw-r--r--dev-python/tempora/tempora-5.3.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/tempora/Manifest b/dev-python/tempora/Manifest
index 1538b4c0d3c9..5578c138987c 100644
--- a/dev-python/tempora/Manifest
+++ b/dev-python/tempora/Manifest
@@ -1 +1,2 @@
DIST tempora-5.2.2.tar.gz 20957 BLAKE2B f8463e544534c0d90bc90da7ed2a829a7afeba54b9c8f21cb831680caba493075b58544560a940d2449e4c9e4803be62413ea1029ee0ce80772ab212ff84a13e SHA512 2031f9ddca66fb0aa93aa1e1162450a3a14e17c41acd19fc657f3c0cd0c058487c9b1377c9f319b15c7f3c39393d184eabfa62038d0493fc3808b6557dfee2cb
+DIST tempora-5.3.0.tar.gz 20735 BLAKE2B 8e93ec6d680bf08877cce21403c8a2bd597980a8df9685c18f03c298fb986c3a6bafd1e8d2a1ab1bcd1b8a928b9259db87aafd6dd9e4eb652be71ab7540251f5 SHA512 0bc82318e275792e0ad7d56ac46b78fd6e75b8fc3b6a57b7138ed7800a2f9f8ef7e64c855bc54ac48e190bfd05e9ea3397b45544e4dcfb2e2905946d76bb2622
diff --git a/dev-python/tempora/tempora-5.3.0.ebuild b/dev-python/tempora/tempora-5.3.0.ebuild
new file mode 100644
index 000000000000..195e0a0d6778
--- /dev/null
+++ b/dev-python/tempora/tempora-5.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Objects and routines pertaining to date and time"
+HOMEPAGE="
+ https://github.com/jaraco/tempora/
+ https://pypi.org/project/tempora/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest