summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-12 08:33:15 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-13 12:40:16 -0400
commit6ba6350cf5f7ef7de0f83b8fb9f6c18caffe63e9 (patch)
treeb6e6a851ee3af700f7b82a7184fd134b8d14ebd7 /dev-qt/qtdeclarative
parentapp-misc/yq: remove unused patch (diff)
downloadgentoo-6ba6350cf5f7ef7de0f83b8fb9f6c18caffe63e9.tar.gz
gentoo-6ba6350cf5f7ef7de0f83b8fb9f6c18caffe63e9.tar.bz2
gentoo-6ba6350cf5f7ef7de0f83b8fb9f6c18caffe63e9.zip
dev-qt/*: add 6.6.9999
Sraight copies from 6.9999, pending updates as-needed to prepare for 6.6 which is slowly approaching (6.9999 been 6.7 for some time). 6.5.9999 will be leaving soon given 6.5.3 is the last 6.5 release for plebians. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtdeclarative')
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-6.6.9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-qt/qtdeclarative/qtdeclarative-6.6.9999.ebuild b/dev-qt/qtdeclarative/qtdeclarative-6.6.9999.ebuild
new file mode 100644
index 000000000000..90ce21a2e8ec
--- /dev/null
+++ b/dev-qt/qtdeclarative/qtdeclarative-6.6.9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Qt Declarative (Quick 2)"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="opengl +sql vulkan +widgets"
+
+# behaves very badly when qtdeclarative is not already installed, also
+# other more minor issues (installs junk, sandbox/offscreen issues)
+RESTRICT="test"
+
+RDEPEND="~dev-qt/qtbase-${PV}:6[network,opengl=,sql?,vulkan=,widgets=]"
+DEPEND="${RDEPEND}"
+BDEPEND="~dev-qt/qtshadertools-${PV}:6"
+
+src_configure() {
+ local mycmakeargs=(
+ $(qt_feature opengl)
+ $(qt_feature sql)
+ $(qt_feature widgets)
+ )
+
+ qt6-build_src_configure
+}