summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-08 05:27:34 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-09 12:06:32 -0400
commite69ee1b26d41ce7a3edeb96e2c48ab3b64e6ae4a (patch)
tree6693aac543cec4a3477f4db1e83bda3c33ad259d /dev-qt/qtscxml
parentdev-qt/qtquick3d: tighten deps a bit (diff)
downloadgentoo-e69ee1b26d41ce7a3edeb96e2c48ab3b64e6ae4a.tar.gz
gentoo-e69ee1b26d41ce7a3edeb96e2c48ab3b64e6ae4a.tar.bz2
gentoo-e69ee1b26d41ce7a3edeb96e2c48ab3b64e6ae4a.zip
dev-qt/qtscxml: tighten deps, make qml optional
Missed that qml could be reasonably optional here. And cannot find where it would need the rest outside examples. Gui could technically be optional but would need its own USE. Do not think it is worth it here unless someone wants this. Maybe missing it, but failed to find anything at all using opengl, it is listed in the docs but...? Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtscxml')
-rw-r--r--dev-qt/qtscxml/metadata.xml3
-rw-r--r--dev-qt/qtscxml/qtscxml-6.5.2-r1.ebuild (renamed from dev-qt/qtscxml/qtscxml-6.5.2.ebuild)16
-rw-r--r--dev-qt/qtscxml/qtscxml-6.5.9999.ebuild16
-rw-r--r--dev-qt/qtscxml/qtscxml-6.9999.ebuild16
4 files changed, 42 insertions, 9 deletions
diff --git a/dev-qt/qtscxml/metadata.xml b/dev-qt/qtscxml/metadata.xml
index 702f3c500dd7..ef86286201dd 100644
--- a/dev-qt/qtscxml/metadata.xml
+++ b/dev-qt/qtscxml/metadata.xml
@@ -5,6 +5,9 @@
<email>qt@gentoo.org</email>
<name>Gentoo Qt Project</name>
</maintainer>
+ <use>
+ <flag name="qml">Build QML/QtQuick bindings and imports</flag>
+ </use>
<upstream>
<bugs-to>https://bugreports.qt.io/</bugs-to>
<doc>https://doc.qt.io/</doc>
diff --git a/dev-qt/qtscxml/qtscxml-6.5.2.ebuild b/dev-qt/qtscxml/qtscxml-6.5.2-r1.ebuild
index c3e29fd2e2f0..3baf824212bc 100644
--- a/dev-qt/qtscxml/qtscxml-6.5.2.ebuild
+++ b/dev-qt/qtscxml/qtscxml-6.5.2-r1.ebuild
@@ -11,14 +11,24 @@ if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64"
fi
+IUSE="qml"
+
RDEPEND="
- ~dev-qt/qtbase-${PV}:6[gui,network,opengl,widgets]
- ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtbase-${PV}:6[gui]
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
"
DEPEND="${RDEPEND}"
CMAKE_SKIP_TESTS=(
# may fail with pid-sandbox, or at least musl/hardened+gcc (exact
- # conditions unknown but passes without pid, consider flaky)
+ # conditions unknown but passes without pid, considering this flaky)
tst_qstatemachine
)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ )
+
+ qt6-build_src_configure
+}
diff --git a/dev-qt/qtscxml/qtscxml-6.5.9999.ebuild b/dev-qt/qtscxml/qtscxml-6.5.9999.ebuild
index c3e29fd2e2f0..3baf824212bc 100644
--- a/dev-qt/qtscxml/qtscxml-6.5.9999.ebuild
+++ b/dev-qt/qtscxml/qtscxml-6.5.9999.ebuild
@@ -11,14 +11,24 @@ if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64"
fi
+IUSE="qml"
+
RDEPEND="
- ~dev-qt/qtbase-${PV}:6[gui,network,opengl,widgets]
- ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtbase-${PV}:6[gui]
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
"
DEPEND="${RDEPEND}"
CMAKE_SKIP_TESTS=(
# may fail with pid-sandbox, or at least musl/hardened+gcc (exact
- # conditions unknown but passes without pid, consider flaky)
+ # conditions unknown but passes without pid, considering this flaky)
tst_qstatemachine
)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ )
+
+ qt6-build_src_configure
+}
diff --git a/dev-qt/qtscxml/qtscxml-6.9999.ebuild b/dev-qt/qtscxml/qtscxml-6.9999.ebuild
index c3e29fd2e2f0..3baf824212bc 100644
--- a/dev-qt/qtscxml/qtscxml-6.9999.ebuild
+++ b/dev-qt/qtscxml/qtscxml-6.9999.ebuild
@@ -11,14 +11,24 @@ if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64"
fi
+IUSE="qml"
+
RDEPEND="
- ~dev-qt/qtbase-${PV}:6[gui,network,opengl,widgets]
- ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtbase-${PV}:6[gui]
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
"
DEPEND="${RDEPEND}"
CMAKE_SKIP_TESTS=(
# may fail with pid-sandbox, or at least musl/hardened+gcc (exact
- # conditions unknown but passes without pid, consider flaky)
+ # conditions unknown but passes without pid, considering this flaky)
tst_qstatemachine
)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ )
+
+ qt6-build_src_configure
+}