summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-16 09:02:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-20 00:51:35 +0100
commitdd935560f537ad88a3eea9794103cb6bb3b2bff9 (patch)
tree99f703a2218d1bbe0b56271f769041542a443048 /dev-qt/qtwidgets
parentdev-qt: Switch USE xcb -> X (diff)
downloadgentoo-dd935560f537ad88a3eea9794103cb6bb3b2bff9.tar.gz
gentoo-dd935560f537ad88a3eea9794103cb6bb3b2bff9.tar.bz2
gentoo-dd935560f537ad88a3eea9794103cb6bb3b2bff9.zip
dev-qt: Drop 5.14.0 w/o USE X
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwidgets')
-rw-r--r--dev-qt/qtwidgets/qtwidgets-5.14.0.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-qt/qtwidgets/qtwidgets-5.14.0.ebuild b/dev-qt/qtwidgets/qtwidgets-5.14.0.ebuild
deleted file mode 100644
index 700b6405241e..000000000000
--- a/dev-qt/qtwidgets/qtwidgets-5.14.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-QT5_MODULE="qtbase"
-inherit qt5-build
-
-DESCRIPTION="Set of components for creating classic desktop-style UIs for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-fi
-
-# keep IUSE defaults in sync with qtgui
-IUSE="gles2 gtk +png +xcb"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}[gles2=,png=,xcb?]
- gtk? (
- ~dev-qt/qtgui-${PV}[dbus]
- x11-libs/gtk+:3
- x11-libs/libX11
- x11-libs/pango
- )
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/tools/uic
- src/widgets
- src/plugins/platformthemes
-)
-
-QT5_GENTOO_CONFIG=(
- gtk:gtk3:
- ::widgets
- !:no-widgets:
-)
-
-QT5_GENTOO_PRIVATE_CONFIG=(
- :widgets
-)
-
-src_configure() {
- local myconf=(
- -opengl $(usex gles2 es2 desktop)
- $(qt_use gtk)
- -gui
- $(qt_use png libpng system)
- -widgets
- $(qt_use xcb xcb system)
- $(usex xcb '-xcb-xlib -xcb-xinput -xkb -xkbcommon' '')
- )
- qt5-build_src_configure
-}