summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-21 22:18:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-21 22:38:28 +0100
commit062292c7748574d7f5d34d7e86403b7d9fe5b7a2 (patch)
treecf39b865df0540ef9996166445e907ce0b031268 /dev-qt
parentmedia-video/pipewire: Stabilize 1.2.6 arm, #944334 (diff)
downloadgentoo-062292c7748574d7f5d34d7e86403b7d9fe5b7a2.tar.gz
gentoo-062292c7748574d7f5d34d7e86403b7d9fe5b7a2.tar.bz2
gentoo-062292c7748574d7f5d34d7e86403b7d9fe5b7a2.zip
dev-qt/assistant: add 5.15.16
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/assistant/Manifest2
-rw-r--r--dev-qt/assistant/assistant-5.15.16.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-qt/assistant/Manifest b/dev-qt/assistant/Manifest
index 7c75cdf08a61..77de84c3708d 100644
--- a/dev-qt/assistant/Manifest
+++ b/dev-qt/assistant/Manifest
@@ -1,2 +1,4 @@
DIST qttools-5.15.14-gentoo-kde-1.tar.xz 3944 BLAKE2B 2a90ad35a743b36144be44ad15add4aa1a867776b78a97f98e656570bcae1e8ad4f9dc571bd0cb6587b7a70b5075e35222b39b7747fe4d59b6f8295d33dfe9ae SHA512 c7347b6dcc845dd312d035f83fcccfc43778961519d009371b30ae98bf110bd473f3191495302cfb1ae4de4ab0494c5899f1abe2ba6bc686f35d3f9163a245d3
+DIST qttools-5.15.16-gentoo-kde-1.tar.xz 2340 BLAKE2B 442295bb3dc671067b6555139e016002e5e088ed6e777bb2348e74c893856fe353a6c8dc0376e5657b228324ee5a0719f1e1c5fbbcb8e86aa3b3325f6a4bb884 SHA512 b34f1de482a633d24543429e33944ee97464ea6b655cdd3c23a7c39dc569125268f25008623f7384574a637ef0460d160c42d9010d0e82d693df5be006c16702
DIST qttools-everywhere-opensource-src-5.15.14.tar.xz 8890236 BLAKE2B 738441eb9d7d860c9007b957724726d6d98aa378006f1761ceb1f4106005f0f287b51b29072fa7069b187b5311e044dbb2aef40a35e98a03544d2902575da195 SHA512 c936ed67a7c5d36fadf55ab8ebb9d22d6697a86b34b1c162f472341de31fa14fc2a3116b50d847d46ba953dab0231eae8131634c4ad0dfd4009b7d7f9ba960ae
+DIST qttools-everywhere-opensource-src-5.15.16.tar.xz 8888944 BLAKE2B abe5a62763c40fd9f41aaf78384913cf4831dc92b09caef14420dc844821ee4f6439050615afc30c33e45ed27c0560c1f0ada5c7d38c49f9f1da747694d5ae35 SHA512 5e81de37a5d429dd14d254a0257e6d1ca37c04a92b506d13d918fd3eb799c026978d3d673f6db0f393b598f520cf3a5d647c66de76308f9de9ac5c6951ed9f6b
diff --git a/dev-qt/assistant/assistant-5.15.16.ebuild b/dev-qt/assistant/assistant-5.15.16.ebuild
new file mode 100644
index 000000000000..d980696867be
--- /dev/null
+++ b/dev-qt/assistant/assistant-5.15.16.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
+fi
+
+QT5_MODULE="qttools"
+inherit desktop qt5-build xdg-utils
+
+DESCRIPTION="Tool for viewing on-line documentation in Qt help file format"
+
+IUSE=""
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*[png]
+ =dev-qt/qthelp-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtprintsupport-${QT5_PV}*
+ =dev-qt/qtsql-${QT5_PV}*[sqlite]
+ =dev-qt/qtwidgets-${QT5_PV}*
+"
+RDEPEND="${DEPEND}
+ !dev-qt/${PN}:5
+ !<dev-qt/qtchooser-66-r2
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/assistant/assistant
+)
+
+src_prepare() {
+ sed -e "s/qtHaveModule(webkitwidgets)/false/g" \
+ -i src/assistant/assistant/assistant.pro || die
+
+ qt5-build_src_prepare
+}
+
+src_install() {
+ qt5-build_src_install
+ qt5_symlink_binary_to_path assistant
+
+ doicon -s 32 src/assistant/assistant/images/assistant.png
+ newicon -s 128 src/assistant/assistant/images/assistant-128.png assistant.png
+ make_desktop_entry "${QT5_BINDIR}"/assistant 'Qt 5 Assistant' assistant 'Qt;Development;Documentation'
+}
+
+pkg_postinst() {
+ qt5-build_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ qt5-build_pkg_postrm
+ xdg_icon_cache_update
+}