summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-12 06:32:26 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-12 07:59:33 -0400
commit2a9f73ff59af3859d55607a0b526aca2c75cbb32 (patch)
treedc15e0282562dea8bee357dcbd0cbe86e66df4ee /dev-qt
parentdev-qt/qtquicktimeline: add 6.7.0_rc (diff)
downloadgentoo-2a9f73ff59af3859d55607a0b526aca2c75cbb32.tar.gz
gentoo-2a9f73ff59af3859d55607a0b526aca2c75cbb32.tar.bz2
gentoo-2a9f73ff59af3859d55607a0b526aca2c75cbb32.zip
dev-qt/qtscxml: add 6.7.0_rc
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtscxml/Manifest1
-rw-r--r--dev-qt/qtscxml/qtscxml-6.7.0_rc.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/Manifest b/dev-qt/qtscxml/Manifest
index 49a4c1480ebf..ecfbf58d5c0b 100644
--- a/dev-qt/qtscxml/Manifest
+++ b/dev-qt/qtscxml/Manifest
@@ -1,2 +1,3 @@
DIST qtscxml-everywhere-opensource-src-5.15.12.tar.xz 437972 BLAKE2B 11bd9a22eada2927e98d7d22f8e17150f7e225b1036173cddd82859b84073dd547278c5df6f096a6318755aa853bc16d8ed2a9721282feedde9ff758b404d80c SHA512 c451fa8fc5999aa7e3b3a336503bcf1ccc8992ef27645d003c938166384508d2cc9b35fbd21e9da641ea98a2aaa58834ac85e8713bce25b96e4aef79c3cda976
DIST qtscxml-everywhere-src-6.6.2.tar.xz 1167628 BLAKE2B c1c32a815bf10eaa9b30241a3dbd6302d75131ef10f6ad2aeff10c0698fa82c937b1086e7f4f157c86659be0fa720d863b1723fbd119291ce549ebe5903e0ad6 SHA512 b7058d310dd82d09ca859dae5529d63bcde68a985a4c3f8f00474e2ffcd8f2f1162ffdafe3bb0cfc29769bc53ea4725dc8b68b04a09dcbea653d9afafca2643c
+DIST qtscxml-everywhere-src-6.7.0-rc.tar.xz 1167028 BLAKE2B 509854f77d5181589c755113a51e23ea21d42c7f2b31554f4a07d35b77f260a7c5875be7f15f7387d450d3f62976fa3258196c88f3fc37f2d01f369012af5792 SHA512 7ad2af76e6df1a95c656212e619866f723129a12388563260f2a64b668b0c55efb663e46d7c30ac6b650c07d4ef6c297e3874a0d1366b696ddaa6b15031cba92
diff --git a/dev-qt/qtscxml/qtscxml-6.7.0_rc.ebuild b/dev-qt/qtscxml/qtscxml-6.7.0_rc.ebuild
new file mode 100644
index 000000000000..02fdb8a7936d
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-6.7.0_rc.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # may fail with pid-sandbox, or at least musl/hardened+gcc (exact
+ # conditions unknown but passes without pid, considering this flaky)
+ tst_qstatemachine
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ )
+
+ qt6-build_src_configure
+}