summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2023-07-20 22:31:29 +0300
committerJimi Huotari <chiitoo@gentoo.org>2023-07-20 22:40:59 +0300
commit47604c3bbaffea045f294a1678922f023716ab17 (patch)
tree2ddf46626420e6c8c6533e52ca41c7ade0bc423b /dev-qt
parentdev-qt/qtdeclarative: add 6.5.2 (diff)
downloadgentoo-47604c3bbaffea045f294a1678922f023716ab17.tar.gz
gentoo-47604c3bbaffea045f294a1678922f023716ab17.tar.bz2
gentoo-47604c3bbaffea045f294a1678922f023716ab17.zip
dev-qt/qttools: add 6.5.2
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qttools/Manifest1
-rw-r--r--dev-qt/qttools/qttools-6.5.2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-qt/qttools/Manifest b/dev-qt/qttools/Manifest
index e0c3a2e31376..69e781b90233 100644
--- a/dev-qt/qttools/Manifest
+++ b/dev-qt/qttools/Manifest
@@ -1 +1,2 @@
DIST qttools-everywhere-src-6.5.1.tar.xz 8592428 BLAKE2B 39a8eef639d4dea838b177285af175983e1e626cd82df8b2201b9380c4f62d5ec3560a7096b6f26a48886989be05bda453e487462d9e200577f15c9cb93eb26a SHA512 fa29a29bf9a723f88aaa5654e333daee90d8dc2f5c88653018a5e754c8115eec3c55940897817e0321dd4c9470d6d008e921ab7e20a714028fa38d04753bfb20
+DIST qttools-everywhere-src-6.5.2.tar.xz 8591336 BLAKE2B 37adbaec83938d4dae096b1ab4e49d1693ab2a926b3b61f5b40f45c8f89ba71ae847abf6eab4db26206dfc9896e5a880de489cfe17c942e66383dcf9b6fc7397 SHA512 d5b858b5307b2abfda2786331034a2957afbaba6299955bc3a2489f15bc8c2613b613b0f6f1fdf2aabfa9929a44eeeae3faeb26e0ab176d347e8ddd47f0e8011
diff --git a/dev-qt/qttools/qttools-6.5.2.ebuild b/dev-qt/qttools/qttools-6.5.2.ebuild
new file mode 100644
index 000000000000..e75eadff55af
--- /dev/null
+++ b/dev-qt/qttools/qttools-6.5.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Qt Tools Collection"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="
+ assistant designer distancefieldgenerator +linguist pixeltool
+ qattributionsscanner qdbus qdoc qdiag qplugininfo
+"
+
+DEPEND="
+ =dev-qt/qtbase-${PV}*[network]
+ assistant? ( =dev-qt/qtbase-${PV}*[sql,widgets] )
+ designer? ( =dev-qt/qtbase-${PV}*[widgets] )
+ distancefieldgenerator? (
+ =dev-qt/qtbase-${PV}*[widgets]
+ =dev-qt/qtdeclarative-${PV}*
+ )
+ pixeltool? ( =dev-qt/qtbase-${PV}*[widgets] )
+ qdbus? ( =dev-qt/qtbase-${PV}*[widgets] )
+ qdoc? ( sys-devel/clang:= )
+ qdiag? ( =dev-qt/qtbase-${PV}*[opengl,widgets] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(qt_feature assistant)
+ -DQT_FEATURE_commandlineparser=ON
+ $(qt_feature designer)
+ $(qt_feature distancefieldgenerator)
+ $(qt_feature linguist)
+ $(qt_feature pixeltool)
+ $(qt_feature qattributionsscanner qtattributionsscanner)
+ $(qt_feature qdbus)
+ $(qt_feature qdoc clang)
+ $(qt_feature qdiag qtdiag)
+ $(qt_feature qplugininfo qtplugininfo)
+ -DQT_FEATURE_thread=ON
+ )
+
+ qt6-build_src_configure
+}
+
+src_install() {
+ qt6-build_src_install
+
+ use assistant && qt6_symlink_binary_to_path assistant 6
+ use designer && qt6_symlink_binary_to_path designer 6
+ use distancefieldgenerator && qt6_symlink_binary_to_path qdistancefieldgenerator 6
+ use linguist && qt6_symlink_binary_to_path linguist 6
+ use pixeltool && qt6_symlink_binary_to_path pixeltool 6
+ use qdbus && qt6_symlink_binary_to_path qdbus 6
+ use qdbus && qt6_symlink_binary_to_path qdbusviewer 6
+ use qdoc && qt6_symlink_binary_to_path qdoc 6
+ use qdiag && qt6_symlink_binary_to_path qtdiag 6
+ use qplugininfo && qt6_symlink_binary_to_path qtplugininfo 6
+}