summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-06 06:12:29 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-06 06:32:38 -0400
commitf2c0be9302270ad97d4b9a434adea3402fd6282b (patch)
tree2ef9bcfae682916080a6320ba99a7a684dc519dd /dev-qt
parentnet-misc/curl: disable pthreads for mingw cross (diff)
downloadgentoo-f2c0be9302270ad97d4b9a434adea3402fd6282b.tar.gz
gentoo-f2c0be9302270ad97d4b9a434adea3402fd6282b.tar.bz2
gentoo-f2c0be9302270ad97d4b9a434adea3402fd6282b.zip
dev-qt/qtwayland: make compositor APIs off-by-default optional (qt6)
asturm pointed out that almost nobody should need this, and I can only agree, it's also the biggest part of the sources and is kind of wasteful. Revbump for correctness, albeit not super useful here. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwayland/metadata.xml1
-rw-r--r--dev-qt/qtwayland/qtwayland-6.5.2-r3.ebuild (renamed from dev-qt/qtwayland/qtwayland-6.5.2-r2.ebuild)7
-rw-r--r--dev-qt/qtwayland/qtwayland-6.5.9999.ebuild7
-rw-r--r--dev-qt/qtwayland/qtwayland-6.9999.ebuild7
4 files changed, 16 insertions, 6 deletions
diff --git a/dev-qt/qtwayland/metadata.xml b/dev-qt/qtwayland/metadata.xml
index fe0b049a950d..1509a2e738a9 100644
--- a/dev-qt/qtwayland/metadata.xml
+++ b/dev-qt/qtwayland/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Qt Project</name>
</maintainer>
<use>
+ <flag name="compositor">Enable support for the wayland compositor / server APIs</flag>
<flag name="qml">Build QML/QtQuick bindings and imports</flag>
<flag name="vulkan">Enable support for Vulkan-based server buffer integration</flag>
</use>
diff --git a/dev-qt/qtwayland/qtwayland-6.5.2-r2.ebuild b/dev-qt/qtwayland/qtwayland-6.5.2-r3.ebuild
index accf21a914e6..9cd6abd6eecf 100644
--- a/dev-qt/qtwayland/qtwayland-6.5.2-r2.ebuild
+++ b/dev-qt/qtwayland/qtwayland-6.5.2-r3.ebuild
@@ -11,14 +11,16 @@ if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64"
fi
-IUSE="qml vulkan"
+IUSE="compositor qml vulkan"
RDEPEND="
dev-libs/wayland
~dev-qt/qtbase-${PV}:6[egl(+),gui,opengl,vulkan=]
media-libs/libglvnd
x11-libs/libxkbcommon
- qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+ compositor? (
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+ )
"
DEPEND="
${RDEPEND}
@@ -42,6 +44,7 @@ PATCHES=(
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package qml Qt6Quick)
+ $(qt_feature compositor wayland_server)
)
qt6-build_src_configure
diff --git a/dev-qt/qtwayland/qtwayland-6.5.9999.ebuild b/dev-qt/qtwayland/qtwayland-6.5.9999.ebuild
index 7319f5b43fd6..517bfcaf25e0 100644
--- a/dev-qt/qtwayland/qtwayland-6.5.9999.ebuild
+++ b/dev-qt/qtwayland/qtwayland-6.5.9999.ebuild
@@ -11,14 +11,16 @@ if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64"
fi
-IUSE="qml vulkan"
+IUSE="compositor qml vulkan"
RDEPEND="
dev-libs/wayland
~dev-qt/qtbase-${PV}:6[gui,opengl,vulkan=]
media-libs/libglvnd
x11-libs/libxkbcommon
- qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+ compositor? (
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+ )
"
DEPEND="
${RDEPEND}
@@ -38,6 +40,7 @@ CMAKE_SKIP_TESTS=(
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package qml Qt6Quick)
+ $(qt_feature compositor wayland_server)
)
qt6-build_src_configure
diff --git a/dev-qt/qtwayland/qtwayland-6.9999.ebuild b/dev-qt/qtwayland/qtwayland-6.9999.ebuild
index 7319f5b43fd6..517bfcaf25e0 100644
--- a/dev-qt/qtwayland/qtwayland-6.9999.ebuild
+++ b/dev-qt/qtwayland/qtwayland-6.9999.ebuild
@@ -11,14 +11,16 @@ if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64"
fi
-IUSE="qml vulkan"
+IUSE="compositor qml vulkan"
RDEPEND="
dev-libs/wayland
~dev-qt/qtbase-${PV}:6[gui,opengl,vulkan=]
media-libs/libglvnd
x11-libs/libxkbcommon
- qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+ compositor? (
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+ )
"
DEPEND="
${RDEPEND}
@@ -38,6 +40,7 @@ CMAKE_SKIP_TESTS=(
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package qml Qt6Quick)
+ $(qt_feature compositor wayland_server)
)
qt6-build_src_configure