summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-04 13:19:26 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-04 14:23:11 +0100
commit9e6153ac457e8c5b08c8a3cac5e455426bf338df (patch)
treea33afb3108157cf74919d4987ea3c2743dbb3002 /dev-ros/bondcpp/bondcpp-1.8.1.ebuild
parentdev-ros/bond: Bump to 1.8.1. (diff)
downloadgentoo-9e6153ac457e8c5b08c8a3cac5e455426bf338df.tar.gz
gentoo-9e6153ac457e8c5b08c8a3cac5e455426bf338df.tar.bz2
gentoo-9e6153ac457e8c5b08c8a3cac5e455426bf338df.zip
dev-ros/bondcpp: Bump to 1.8.1.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/bondcpp/bondcpp-1.8.1.ebuild')
-rw-r--r--dev-ros/bondcpp/bondcpp-1.8.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/bondcpp/bondcpp-1.8.1.ebuild b/dev-ros/bondcpp/bondcpp-1.8.1.ebuild
new file mode 100644
index 000000000000..123e756ecdab
--- /dev/null
+++ b/dev-ros/bondcpp/bondcpp-1.8.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ implementation of bond, a mechanism for checking when another process has terminated"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bond
+ dev-ros/cmake_modules
+ dev-ros/roscpp
+ dev-ros/smclib
+ dev-libs/boost:=
+ sys-apps/util-linux
+"
+DEPEND="${RDEPEND}"