summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-28 17:26:14 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-28 20:10:14 +0100
commitb8e696017e968e94a5e38ab5faa87b111ba1b7c9 (patch)
treedda3b465a7401ece35f27eabb206bb510d20929b /dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.15.1-r1.ebuild
parentdev-ros/clear_costmap_recovery: Remove old (diff)
downloadgentoo-b8e696017e968e94a5e38ab5faa87b111ba1b7c9.tar.gz
gentoo-b8e696017e968e94a5e38ab5faa87b111ba1b7c9.tar.bz2
gentoo-b8e696017e968e94a5e38ab5faa87b111ba1b7c9.zip
dev-ros/clear_costmap_recovery: add missing := dep on console_bridge
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.15.1-r1.ebuild')
-rw-r--r--dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.15.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.15.1-r1.ebuild b/dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.15.1-r1.ebuild
new file mode 100644
index 000000000000..131722880ad5
--- /dev/null
+++ b/dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.15.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Recovery behavior that attempts to clear space by reverting the costmaps to the static map"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/costmap_2d-1.13.1
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-cpp/eigen:3
+ sci-libs/pcl
+ dev-libs/boost:=[threads]
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? ( dev-ros/rostest dev-cpp/gtest )
+"