summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-05-18 16:56:33 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-05-18 17:18:23 +0200
commit9cba4a2b00bdd4bd91db549fe73efcbf4242c229 (patch)
tree5c368498c65c9dd1627cf22fea565bcd6ea4d0b0 /dev-ros/gazebo_plugins/gazebo_plugins-2.8.7.ebuild
parentdev-ros/gazebo_msgs: Bump to 2.8.7. (diff)
downloadgentoo-9cba4a2b00bdd4bd91db549fe73efcbf4242c229.tar.gz
gentoo-9cba4a2b00bdd4bd91db549fe73efcbf4242c229.tar.bz2
gentoo-9cba4a2b00bdd4bd91db549fe73efcbf4242c229.zip
dev-ros/gazebo_plugins: Bump to 2.8.7.
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/gazebo_plugins/gazebo_plugins-2.8.7.ebuild')
-rw-r--r--dev-ros/gazebo_plugins/gazebo_plugins-2.8.7.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-ros/gazebo_plugins/gazebo_plugins-2.8.7.ebuild b/dev-ros/gazebo_plugins/gazebo_plugins-2.8.7.ebuild
new file mode 100644
index 000000000000..88ed4a6fdf55
--- /dev/null
+++ b/dev-ros/gazebo_plugins/gazebo_plugins-2.8.7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Robot-independent Gazebo plugins for sensors, motors and dynamic reconfigurable components"
+LICENSE="BSD Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/gazebo_dev
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/nodelet
+ dev-ros/angles
+ dev-ros/std_srvs
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/urdf
+ dev-ros/tf
+ dev-ros/tf2_ros
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/driver_base[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/trajectory_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pcl_conversions
+ dev-ros/image_transport
+ dev-ros/rosconsole
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/polled_camera
+ dev-ros/diagnostic_updater
+ dev-ros/camera_info_manager
+ dev-ros/moveit_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/libxml2
+ >=sci-electronics/gazebo-7:=
+ dev-libs/protobuf:=
+ dev-games/ogre
+ sci-libs/pcl
+ dev-libs/boost:=
+ dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"