summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-14 16:36:45 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-15 07:57:40 +0100
commit781e0c54c6033c6e52aa1aae033278b568cc09cf (patch)
tree83156e424444d35b8cc0adcf6224078c1b9d6a70 /dev-ros/image_geometry/image_geometry-1.12.7.ebuild
parentdev-ros/cv_bridge: Bump to 1.12.7. (diff)
downloadgentoo-781e0c54c6033c6e52aa1aae033278b568cc09cf.tar.gz
gentoo-781e0c54c6033c6e52aa1aae033278b568cc09cf.tar.bz2
gentoo-781e0c54c6033c6e52aa1aae033278b568cc09cf.zip
dev-ros/image_geometry: Bump to 1.12.7.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/image_geometry/image_geometry-1.12.7.ebuild')
-rw-r--r--dev-ros/image_geometry/image_geometry-1.12.7.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/image_geometry/image_geometry-1.12.7.ebuild b/dev-ros/image_geometry/image_geometry-1.12.7.ebuild
new file mode 100644
index 000000000000..8206600adc38
--- /dev/null
+++ b/dev-ros/image_geometry/image_geometry-1.12.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ and Python libraries for interpreting images geometrically"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ media-libs/opencv:=
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] dev-cpp/gtest )"