summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 14:02:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 14:02:03 +0200
commitc2045e62ea5db51ac09d685bba130c8958d811df (patch)
treee6853c48252982e9dbd231f1a55ad8698d5b6cc6 /dev-ros/image_rotate/image_rotate-9999.ebuild
parentdev-ros/image_proc: Initial import. Ebuild by me. (diff)
downloadgentoo-c2045e62ea5db51ac09d685bba130c8958d811df.tar.gz
gentoo-c2045e62ea5db51ac09d685bba130c8958d811df.tar.bz2
gentoo-c2045e62ea5db51ac09d685bba130c8958d811df.zip
dev-ros/image_rotate: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/image_rotate/image_rotate-9999.ebuild')
-rw-r--r--dev-ros/image_rotate/image_rotate-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/image_rotate/image_rotate-9999.ebuild b/dev-ros/image_rotate/image_rotate-9999.ebuild
new file mode 100644
index 000000000000..7ee1973e6eb0
--- /dev/null
+++ b/dev-ros/image_rotate/image_rotate-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Rotates an image stream minimizing the angle between an arbitrary vector and the camera frame"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/eigen_conversions
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs
+"
+DEPEND="${RDEPEND}"