summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-28 14:04:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-03-29 00:18:23 +0200
commitcc0c3fe81a0dd24e77d022b4b1a8ec387a86f27d (patch)
tree664cf86895728b3472df3ee3a393252ddd059533 /dev-ros/joint_state_publisher/joint_state_publisher-1.12.8.ebuild
parentdev-ros/collada_urdf: Bump to 1.12.8. (diff)
downloadgentoo-cc0c3fe81a0dd24e77d022b4b1a8ec387a86f27d.tar.gz
gentoo-cc0c3fe81a0dd24e77d022b4b1a8ec387a86f27d.tar.bz2
gentoo-cc0c3fe81a0dd24e77d022b4b1a8ec387a86f27d.zip
dev-ros/joint_state_publisher: Bump to 1.12.8.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/joint_state_publisher/joint_state_publisher-1.12.8.ebuild')
-rw-r--r--dev-ros/joint_state_publisher/joint_state_publisher-1.12.8.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/joint_state_publisher/joint_state_publisher-1.12.8.ebuild b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.8.ebuild
new file mode 100644
index 000000000000..7a7a68e62676
--- /dev/null
+++ b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.8.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/robot_model"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for setting and publishing joint state values for a given URDF"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"