summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-04 11:50:36 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-04 12:12:35 +0100
commita66c2acdd183245e0258e36aa40f58eb479bc6a3 (patch)
tree58d78cd4caa3140978389737480adbeb5c71f5c1 /dev-ros/opencv_tests/opencv_tests-1.11.11.ebuild
parentdev-ros/image_geometry: Bump to 1.11.11. (diff)
downloadgentoo-a66c2acdd183245e0258e36aa40f58eb479bc6a3.tar.gz
gentoo-a66c2acdd183245e0258e36aa40f58eb479bc6a3.tar.bz2
gentoo-a66c2acdd183245e0258e36aa40f58eb479bc6a3.zip
dev-ros/opencv_tests: Bump to 1.11.11.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/opencv_tests/opencv_tests-1.11.11.ebuild')
-rw-r--r--dev-ros/opencv_tests/opencv_tests-1.11.11.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/opencv_tests/opencv_tests-1.11.11.ebuild b/dev-ros/opencv_tests/opencv_tests-1.11.11.ebuild
new file mode 100644
index 000000000000..770ea0be049c
--- /dev/null
+++ b/dev-ros/opencv_tests/opencv_tests-1.11.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+# Be careful: It needs opencv with python support but opencv is python-single-r1
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tests for ROS OpenCV integration"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ media-libs/opencv[python,python_single_target_python2_7]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ ros-catkin_src_install
+ insinto /usr/share/${PN}/launch
+ doins launch/*.launch
+ exeinto /usr/libexec/${PN}
+ doexe nodes/*
+}